summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.7.3.ebuild93
-rw-r--r--dev-python/nbconvert/nbconvert-7.7.4.ebuild93
3 files changed, 0 insertions, 188 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index d2ebbcc9f44a..55201c9c2091 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,3 +1 @@
-DIST nbconvert-7.7.3.tar.gz 849762 BLAKE2B a887fc2bbb7978fdcabbaa46ea391a9b42ba904609ee0a67fc59f1d66373ee2d4cc6328b4c39a7deb77f5bb87c503dc61f7c3a5ce04e36a8149fe7ece42fab46 SHA512 8b6f5b05c89e4931716ecd7de1d16be54284a0c5699439f896f9c08bf3d88f930e6e6cf2fa688132a6c7b93ccd11be9526cc08732d4c28ccf3854f402e21fe82
-DIST nbconvert-7.7.4.tar.gz 849858 BLAKE2B e7260b7cd6d315fc7ca70ef272a72b2b85557813caadc5c89964a21cf85c5cda186921d16685f2abc8f0a34b1b78a9c5c03b8bbb5308a31363f6af3ecbd4c721 SHA512 4af508cabfcff9c3bfd56fcb7e002f3af0a3edb1209ffb6dd48ab79f8ce24d0d7abe87398117fe41dd8d704bb8bf292a785826f1bb6e8be124a761a317fcb015
DIST nbconvert-7.8.0.tar.gz 850287 BLAKE2B c499f9df8dd7eb4d337f0b7b6f79cb6046361900747fc1cbd84426b2fda35f9e453002341b322b32f04187e0fd3e375dcc4338e3b4bc7455ddc4f2185a69ed1d SHA512 e332f5561050244c79e728c71e51b9ecd66c99c1550bb95bc3cb710b1bb67a3513c0a7c00cb3e333c032e5228f251b7be036162c77cb375900c5eacc923fc197
diff --git a/dev-python/nbconvert/nbconvert-7.7.3.ebuild b/dev-python/nbconvert/nbconvert-7.7.3.ebuild
deleted file mode 100644
index c503ec9a03d4..000000000000
--- a/dev-python/nbconvert/nbconvert-7.7.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing pypi virtualx
-
-DESCRIPTION="Converting Jupyter Notebooks"
-HOMEPAGE="
- https://nbconvert.readthedocs.io/
- https://github.com/jupyter/nbconvert/
- https://pypi.org/project/nbconvert/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
- dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
- <dev-python/mistune-4[${PYTHON_USEDEP}]
- >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
- dev-python/tinycss2[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- mkdir -p share/templates/classic/static || die
- # tries to refetch stuff even if it's already present
- sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
- -i hatch_build.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Missing pyppeteer for now
- # TODO: Doesn't skip?
- nbconvert/exporters/tests/test_webpdf.py
- # Needs pyppeteer too
- 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
- # TODO
- nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
- # latex failing, might be too new pandoc
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_filename_spaces
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_pdf
- # too new pandoc but we don't have old anymore
- nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_minimal_version
- nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_pandoc_available
- # crazy qtweb* stuff, perhaps permissions
- nbconvert/exporters/tests/test_qtpdf.py::TestQtPDFExporter::test_export
- )
-
- # virtx implies nonfatal, make it explicit to avoid confusion
- nonfatal epytest -n "$(makeopts_jobs)" --pyargs nbconvert || die
-}
-
-pkg_postinst() {
- if ! has_version virtual/pandoc; then
- einfo "Pandoc is required for converting to formats other than Python,"
- einfo "HTML, and Markdown. If you need this functionality, install"
- einfo "app-text/pandoc or app-text/pandoc-bin."
- fi
-}
diff --git a/dev-python/nbconvert/nbconvert-7.7.4.ebuild b/dev-python/nbconvert/nbconvert-7.7.4.ebuild
deleted file mode 100644
index 8243caec62c7..000000000000
--- a/dev-python/nbconvert/nbconvert-7.7.4.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing pypi virtualx
-
-DESCRIPTION="Converting Jupyter Notebooks"
-HOMEPAGE="
- https://nbconvert.readthedocs.io/
- https://github.com/jupyter/nbconvert/
- https://pypi.org/project/nbconvert/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
- dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
- <dev-python/mistune-4[${PYTHON_USEDEP}]
- >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
- dev-python/tinycss2[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- mkdir -p share/templates/classic/static || die
- # tries to refetch stuff even if it's already present
- sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
- -i hatch_build.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Missing pyppeteer for now
- # TODO: Doesn't skip?
- nbconvert/exporters/tests/test_webpdf.py
- # Needs pyppeteer too
- 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
- # TODO
- nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
- # latex failing, might be too new pandoc
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_filename_spaces
- nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_pdf
- # too new pandoc but we don't have old anymore
- nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_minimal_version
- nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_pandoc_available
- # crazy qtweb* stuff, perhaps permissions
- nbconvert/exporters/tests/test_qtpdf.py::TestQtPDFExporter::test_export
- )
-
- # virtx implies nonfatal, make it explicit to avoid confusion
- nonfatal epytest -n "$(makeopts_jobs)" --pyargs nbconvert || die
-}
-
-pkg_postinst() {
- if ! has_version virtual/pandoc; then
- einfo "Pandoc is required for converting to formats other than Python,"
- einfo "HTML, and Markdown. If you need this functionality, install"
- einfo "app-text/pandoc or app-text/pandoc-bin."
- fi
-}