summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Lirc-Client')
-rw-r--r--dev-perl/Lirc-Client/Lirc-Client-1.540.0-r1.ebuild23
-rw-r--r--dev-perl/Lirc-Client/Lirc-Client-2.20.0.ebuild29
-rw-r--r--dev-perl/Lirc-Client/Manifest2
-rw-r--r--dev-perl/Lirc-Client/metadata.xml10
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/Lirc-Client/Lirc-Client-1.540.0-r1.ebuild b/dev-perl/Lirc-Client/Lirc-Client-1.540.0-r1.ebuild
new file mode 100644
index 000000000000..cc46851658f6
--- /dev/null
+++ b/dev-perl/Lirc-Client/Lirc-Client-1.540.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MGRIMES
+MODULE_VERSION=1.54
+inherit perl-module
+
+DESCRIPTION="A client library for the Linux Infrared Remote Control (LIRC)"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/File-Path-Expand
+ dev-perl/Class-Accessor"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+# tests succeed - only tested without lirc - tove
+#SRC_TEST=do
diff --git a/dev-perl/Lirc-Client/Lirc-Client-2.20.0.ebuild b/dev-perl/Lirc-Client/Lirc-Client-2.20.0.ebuild
new file mode 100644
index 000000000000..c2a011e14e0c
--- /dev/null
+++ b/dev-perl/Lirc-Client/Lirc-Client-2.20.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MGRIMES
+MODULE_VERSION=2.02
+inherit perl-module
+
+DESCRIPTION="A client library for the Linux Infrared Remote Control (LIRC)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/File-Path-Expand
+ >=dev-perl/Moo-1.0.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Lirc-Client/Manifest b/dev-perl/Lirc-Client/Manifest
new file mode 100644
index 000000000000..276ec749c1b7
--- /dev/null
+++ b/dev-perl/Lirc-Client/Manifest
@@ -0,0 +1,2 @@
+DIST Lirc-Client-1.54.tar.gz 12870 SHA256 a0b57cd2157539382d41806a6006210fb95e49bf14be07793eca8bf69c7fca8f SHA512 3643b5d9cd097bc88cfe7871db2aac0cc23c549b1cc19992d9882f5cd19cd33fc4a0dc7a4ba87bcd51bca253956650862648f987c6625efdfcc5d23abcf4d561 WHIRLPOOL 35f9c117f14a5ab087f3a9d57f4bf8792a3a7902baf98f87a24dcac4a078a998267786b0b42c18f88a15da64e26ed7f664cb64b2b6d2b417ca97084bde8dda15
+DIST Lirc-Client-2.02.tar.gz 14255 SHA256 1309874204090b9710eda6e9ffb2e9b6a64ca04ef4bb0885c90a7ea221f47773 SHA512 4fc0c72b089b97ec600d2860969cfdfc85d9d0be529f37d0a15bcac30b742482f5e6f0b535623ba1ca412a5e172378987c7deed207ce634d1dacc4c47d316431 WHIRLPOOL 415ba5a82ad913216a7701482c16dc6ad2bbf1cc0e31bfca2756ed5d16b63a4ae595bbed5bb4cfe3589120254f972aba11a1ad2bebb3e16604b9243d31c21a34
diff --git a/dev-perl/Lirc-Client/metadata.xml b/dev-perl/Lirc-Client/metadata.xml
new file mode 100644
index 000000000000..70df497571b3
--- /dev/null
+++ b/dev-perl/Lirc-Client/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Lirc-Client</remote-id>
+ <remote-id type="cpan-module">Lirc::Client</remote-id>
+ </upstream>
+</pkgmetadata>