summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_optcomp/files/oc44.patch31
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ml/ppx_optcomp/files/oc44.patch b/dev-ml/ppx_optcomp/files/oc44.patch
new file mode 100644
index 000000000000..332b58b98884
--- /dev/null
+++ b/dev-ml/ppx_optcomp/files/oc44.patch
@@ -0,0 +1,31 @@
+Index: ppx_optcomp-113.33.00/src/ppx_optcomp.ml
+===================================================================
+--- ppx_optcomp-113.33.00.orig/src/ppx_optcomp.ml
++++ ppx_optcomp-113.33.00/src/ppx_optcomp.ml
+@@ -552,7 +552,7 @@ end = struct
+
+ let rec next_directive (lexer : lexer) lexbuf =
+ match lexer lexbuf with
+- | SHARP -> parse_directive lexer lexbuf
++ | HASH -> parse_directive lexer lexbuf
+ | EOL -> next_directive lexer lexbuf
+ | EOF -> endif_missing lexbuf
+ | _ -> skip_line lexer lexbuf; next_directive lexer lexbuf
+@@ -647,7 +647,7 @@ end = struct
+ (* Return the next token from a stream, interpreting directives. *)
+ let rec lexer_internal (lexer : lexer) lexbuf : Parser.token =
+ match lexer lexbuf with
+- | SHARP when at_bol lexbuf ->
++ | HASH when at_bol lexbuf ->
+ interpret_directive lexer lexbuf (parse_directive lexer lexbuf);
+ lexer_internal lexer lexbuf
+ | EOF -> Stack.check_eof lexbuf; EOF
+@@ -749,7 +749,7 @@ end = struct
+ Location.init lexbuf fn;
+ let rec loop pos acc =
+ match Lexer.token lexbuf with
+- | SHARP when at_bol lexbuf ->
++ | HASH when at_bol lexbuf ->
+ let acc = (pos, Lexing.lexeme_start lexbuf) :: acc in
+ interpret_directive Lexer.token lexbuf (parse_directive Lexer.token lexbuf);
+ loop (Lexing.lexeme_end lexbuf) acc
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
index f3ad68d7ea84..873416da7ac0 100644
--- a/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,6 +22,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+ has_version '>=dev-lang/ocaml-4.04' && epatch "${FILESDIR}/oc44.patch"
}
src_configure() {