summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/zig/zig-0.8.1-r1.ebuild')
-rw-r--r--dev-lang/zig/zig-0.8.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/zig/zig-0.8.1-r1.ebuild b/dev-lang/zig/zig-0.8.1-r1.ebuild
index 659a2ac1dbca..86befea8144c 100644
--- a/dev-lang/zig/zig-0.8.1-r1.ebuild
+++ b/dev-lang/zig/zig-0.8.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake llvm
+inherit cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -45,6 +45,9 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
+# see https://github.com/ziglang/zig/wiki/Troubleshooting-Build-Issues#high-memory-requirements
+CHECKREQS_MEMORY="10G"
+
src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF