summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqliteman/sqliteman-1.2.2-r2.ebuild')
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r2.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..b91d1821403a
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="http://sqliteman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[sqlite]
+ x11-libs/qscintilla:=[qt4(-)]"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README )
+PATCHES=( "${FILESDIR}/${P}-lpthread.patch" )
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf "${S}"/${PN}/qscintilla2 || die
+
+ cmake-utils_src_prepare
+}