summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-3.6.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index c9e3a10d3c5c..93484845a6f1 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -4,3 +4,4 @@ DIST Catch2-2.13.8.tar.gz 661711 BLAKE2B 973cc73c1d158140645003e76c0baf85a652520
DIST Catch2-3.5.2.tar.gz 1159985 BLAKE2B 6aa810926f68098a8ac18bf3b045b0bf1be3632e3b34a59561c337312d0501199df7baf49d242c0dd6eeb3f4a9ca77c5545b86092e10865452f7bacaa13ea2a3 SHA512 1b9d5f35144f6c7acef0e76558a4adf3ff41c2c2292fbdcb3e2c2917fa2deb7fba593738105dd3c111f02ee8aca64010cf68f69bb8fb1815dbf771b509ab0576
DIST Catch2-3.5.3.tar.gz 1169512 BLAKE2B ad515d379b071e015f593b3c6a1a66bafa3ca7c083f95ebba59603993a3a8ef40073a883731e83458bb0d463d3e53369e0474a6bdf0aef57e567f13bcc11d6a7 SHA512 57c996f679cbad212cb0fde39e506bade37bd559c0e93e20f407f2a2f029e98b78661e10257f9c8e4cb5fd7d52d0ea1eae3d4a1f989c6d66fcb281e32e1688f6
DIST Catch2-3.5.4.tar.gz 1172449 BLAKE2B 2dee5ca34304032d92bfe147f9beff42c9b1db82b36bb0472a75f911d273cba4d881c3eccac4086eea6a77356defdab4b6d1a54cacd023eb8f904d12969ba60b SHA512 c22ad6a2fbf8665b8775d72dcdc6bfde324eb224fcd897ebce5e62c7ac7640823550198fff45e1ea548a5923db4392ce7009ff784ef78bd59356a2aae5337976
+DIST Catch2-3.6.0.tar.gz 1181300 BLAKE2B 37c56cf5537cb5fb66c1a4a9f15cd0b8e5f993f1f6ab1aa442d15b6290f2b1871abd97bccbdbf22694c4a86c736216c3006d36a82566bc9270704a5a11dc2672 SHA512 09c728a04d69b0692d6e2f7ceb5889dc69309406c27f7f2b5d383245a5357657c5540dd64a7a4a6e19388bda68105002425286468578b69b20e3a75366871ce2
diff --git a/dev-cpp/catch/catch-3.6.0.ebuild b/dev-cpp/catch/catch-3.6.0.ebuild
new file mode 100644
index 000000000000..cde2d006ed7f
--- /dev/null
+++ b/dev-cpp/catch/catch-3.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_DEVELOPMENT_BUILD=ON
+ -DCATCH_ENABLE_WERROR=OFF
+ -DCATCH_BUILD_TESTING=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}