summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index 8c50916e83e9..691afb13f9c1 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -26,11 +26,17 @@ DOCS=( ChangeLog.md README.md )
src_configure() {
local mycmakeargs=(
- -DJSON_BuildTests=$(usex test)
- -DJSON_TestDataDirectory="${S}/json_test_data"
-DJSON_MultipleHeaders=ON
)
+ if use test ; then
+ # Define test data directory here to avoid unused var QA warning
+ # #747826
+ mycmakeargs+=(
+ -DJSON_BuildTests=ON
+ -DJSON_TestDataDirectory="${S}/json_test_data"
+ )
+ fi
cmake_src_configure
}