summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/wanderlust/wanderlust-2.15.9_p20180814.ebuild')
-rw-r--r--app-emacs/wanderlust/wanderlust-2.15.9_p20180814.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/wanderlust/wanderlust-2.15.9_p20180814.ebuild b/app-emacs/wanderlust/wanderlust-2.15.9_p20180814.ebuild
new file mode 100644
index 000000000000..6885a08624db
--- /dev/null
+++ b/app-emacs/wanderlust/wanderlust-2.15.9_p20180814.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Yet Another Message Interface on Emacsen"
+HOMEPAGE="https://github.com/wanderlust/wanderlust"
+GITHUB_SHA1="395826e99b84051396d503392f52462b6cb683a5"
+SRC_URI="${HOMEPAGE}/archive/${GITHUB_SHA1}.tar.gz -> ${P}-git.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bbdb ssl l10n_ja"
+
+DEPEND=">=app-emacs/apel-10.6
+ virtual/emacs-flim
+ app-emacs/semi
+ bbdb? ( app-emacs/bbdb )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ local lang="\"en\""
+ use l10n_ja && lang="${lang} \"ja\""
+ echo "(setq wl-info-lang '(${lang}) wl-news-lang '(${lang}))" >>WL-CFG
+ use ssl && echo "(setq wl-install-utils t)" >>WL-CFG
+}
+
+src_compile() {
+ emake
+ emake info
+}
+
+src_install() {
+ emake \
+ LISPDIR="${ED}${SITELISP}" \
+ PIXMAPDIR="${ED}${SITEETC}/wl/icons" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" wl
+
+ insinto "${SITEETC}/wl/samples/en"
+ doins samples/en/*
+ doinfo doc/wl*.info
+ dodoc BUGS ChangeLog INSTALL NEWS README.md
+
+ if use l10n_ja; then
+ insinto "${SITEETC}/wl/samples/ja"
+ doins samples/ja/*
+ dodoc BUGS.ja INSTALL.ja NEWS.ja README.ja
+ fi
+}