summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ted/ted-2.23.ebuild')
-rw-r--r--app-editors/ted/ted-2.23.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-editors/ted/ted-2.23.ebuild b/app-editors/ted/ted-2.23.ebuild
index 790d41379b1d..47c86d46a256 100644
--- a/app-editors/ted/ted-2.23.ebuild
+++ b/app-editors/ted/ted-2.23.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs xdg-utils
DESCRIPTION="X-based rich text editor"
HOMEPAGE="http://www.nllgg.nl/Ted"
@@ -64,3 +64,11 @@ src_install() {
default
dosym ../share/Ted/examples/rtf2pdf.sh /usr/bin/rtf2pdf.sh
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}