summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/pms/files/pms-5-Makefile.patch24
-rw-r--r--app-doc/pms/files/pms-7-Makefile.patch12
-rw-r--r--app-doc/pms/pms-5_p20120920.ebuild1
-rw-r--r--app-doc/pms/pms-7_p20180430-r1.ebuild2
4 files changed, 39 insertions, 0 deletions
diff --git a/app-doc/pms/files/pms-5-Makefile.patch b/app-doc/pms/files/pms-5-Makefile.patch
new file mode 100644
index 000000000000..5f50404881c7
--- /dev/null
+++ b/app-doc/pms/files/pms-5-Makefile.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -19,19 +19,11 @@
+ @# need to do it twice to make the big env var table work
+ mk4ht xhlatex pms
+ mk4ht xhlatex pms
++ @# ... and a third time for the eapi features table
++ mk4ht xhlatex pms
+ @# some www servers ignore meta tags, resulting in a wrong charset.
+ @# therefore recode the very few non-ascii characters
+ recode -d l1..h3 pms.html
+- @# work around irregularity in how links to longtables are
+- @# formatted in the List of Tables
+- LC_ALL=C sed -i -e '/<span class="lotToc" >&#x00A0;/{N;N;s/\(&#x00A0;<a \nhref="[^"]\+">\)\([0-9A-Z.]\+\)[ \n]/\2\1/}' pms.html
+- @# fix xhtml syntax in longtable captions
+- LC_ALL=C sed -i -e 's%</td>\( *<div class="multicolumn"\)%\1%;tx;b;:x;s%</tr>%</td>&%;t;n;bx' pms.html
+- @# indent algorithms properly, and avoid adding extra vertical
+- @# space in Konqueror
+- LC_ALL=C sed -i -e 's/span style="width:/span style="display:-moz-inline-box;display:inline-block;height:1px;width:/' pms.html
+- @# align algorithm line numbers properly
+- LC_ALL=C sed -i -e '/<span class="ALCitem">/{N;s/\n\(class="[^"]\+">\)\([0-9]:<\/span>\)/\1\&#x2007;\2/}' pms.html
+
+ pms.bbl: pms.bib pms.tex vc.tex eapi-cheatsheet.pdf
+ latex pms
diff --git a/app-doc/pms/files/pms-7-Makefile.patch b/app-doc/pms/files/pms-7-Makefile.patch
new file mode 100644
index 000000000000..d96abd421f0b
--- /dev/null
+++ b/app-doc/pms/files/pms-7-Makefile.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -52,9 +52,6 @@
+ recode -d l1..h3 $@
+ @# declare encoding as utf-8, although it is pure ascii
+ LC_ALL=C sed -i -e '/<?xml\|<meta/s/iso-8859-1/utf-8/' $@
+- @# work around irregularity in how links to longtables are
+- @# formatted in the List of Tables
+- LC_ALL=C sed -i -e '/<span class="lotToc" >&#x00A0;/{N;N;s/\(&#x00A0;<a \nhref="[^"]\+">\)\([0-9A-Z.]\+\)[ \n]\+/\2\1/}' $@
+ @# remove redundant span elements
+ LC_ALL=C sed -i -e ':x;/<span\(\s\+[^>]*\)\?$$/{N;bx;};:y;s/\(<span\s\+[^>]*>\)\([^<]*\)<\/span>\1/\1\2/;ty' $@
+
diff --git a/app-doc/pms/pms-5_p20120920.ebuild b/app-doc/pms/pms-5_p20120920.ebuild
index 7ceaee494365..51d0d7b9b25a 100644
--- a/app-doc/pms/pms-5_p20120920.ebuild
+++ b/app-doc/pms/pms-5_p20120920.ebuild
@@ -27,6 +27,7 @@ BDEPEND="dev-tex/leaflet
RDEPEND="!app-doc/pms-bin"
S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}/${PN}-5-Makefile.patch")
src_compile() {
# just in case; we shouldn't be generating any fonts
diff --git a/app-doc/pms/pms-7_p20180430-r1.ebuild b/app-doc/pms/pms-7_p20180430-r1.ebuild
index a71c1856b811..975b3f69fc83 100644
--- a/app-doc/pms/pms-7_p20180430-r1.ebuild
+++ b/app-doc/pms/pms-7_p20180430-r1.ebuild
@@ -29,6 +29,8 @@ BDEPEND="dev-tex/leaflet
)"
RDEPEND="!app-doc/pms-bin"
+PATCHES=("${FILESDIR}/${PN}-7-Makefile.patch")
+
src_compile() {
# just in case; we shouldn't be generating any fonts
export VARTEXFONTS="${T}/fonts"