summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-gc/docker-gc-9999.ebuild21
-rw-r--r--app-containers/docker-gc/metadata.xml8
2 files changed, 29 insertions, 0 deletions
diff --git a/app-containers/docker-gc/docker-gc-9999.ebuild b/app-containers/docker-gc/docker-gc-9999.ebuild
new file mode 100644
index 000000000000..9324081bc947
--- /dev/null
+++ b/app-containers/docker-gc/docker-gc-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/spotify/docker-gc.git"
+
+inherit git-r3
+
+DESCRIPTION="Docker garbage collection of containers and images"
+HOMEPAGE="https://github.com/spotify/docker-gc/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="app-emulation/docker"
+
+src_install() {
+ dosbin docker-gc
+ dodoc README.md
+}
diff --git a/app-containers/docker-gc/metadata.xml b/app-containers/docker-gc/metadata.xml
new file mode 100644
index 000000000000..aa29b5baad9d
--- /dev/null
+++ b/app-containers/docker-gc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">spotify/docker-gc</remote-id>
+ </upstream>
+</pkgmetadata>