summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/httpclient/Manifest1
-rw-r--r--dev-ruby/httpclient/httpclient-2.7.1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index d1931a88763b..c8b58c0331f6 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,3 +1,2 @@
-DIST httpclient-2.7.1.tgz 457036 SHA256 d176c5177745d60434a05c3d85497f9a56c725aa6f9ee98ac14349f9ffe05cfc SHA512 960770fe351a82e4008ca706bc0f1c7ba255b67dcbcc2984b1f76b78bdb9236b799dbd81c98d706a6a3755677b8d11fe7d7dd5b3af6afaaf901d70d999a09ea2 WHIRLPOOL d6c70683f702c2b749d56ff011beb24e8b4d77acab6f587986e44ecd6a3c6ac73059b4080715b97b750d773c1c13bf4abcb91a0748087e233b0509b2592daa1d
DIST httpclient-2.8.2.4.tgz 462907 SHA256 82c4a08d35f905a3031cdbdaaf838303cd90aaec7edfa12247c0f649c0dba397 SHA512 c225f302e6bd1f08fc089c202d4d870999ae9ef4bf1df416fb7f06b1732f50b9a7c69a5b73f1ee2f963665d5d436c243830555f8d42c60ac536abbae72b693a5 WHIRLPOOL 732c1c2ad18d47e0c424fc5922ab919f98e0df2e1f369ca43b212334f64944428caaafdaaee9b4f6e6952833282268d818f61211158579407074538faf7415cf
DIST httpclient-2.8.3.tgz 464624 SHA256 647f054736dbe5357eeb722e837b6e30d7ed60939302145cd6099eca3ab8810b SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d WHIRLPOOL 63a290d7cca6389eb3d947aa4245b8c88c53020c2afd6695fcdf74e0e4119986f235a3c02c19855772f7cf2dd977329e54cf062a6640b51eb01bf5fc5a3fea48
diff --git a/dev-ruby/httpclient/httpclient-2.7.1.ebuild b/dev-ruby/httpclient/httpclient-2.7.1.ebuild
deleted file mode 100644
index ba0a3ab8ebb8..000000000000
--- a/dev-ruby/httpclient/httpclient-2.7.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="Ruby"
-SLOT="0"
-
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- !dev-ruby/http-access2"
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Fix documentation task
- sed -i -e 's/README.txt/README.md/' Rakefile || die
-
- # Remove mandatory CI reports since we don't need this for testing.
- sed -i -e '/reporter/s:^:#:' Rakefile || die
-
- # Remove mandatory simplecov dependency
- sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-
- # Skip tests using rack-ntlm which is not packaged. Weirdly these
- # only fail on jruby.
- rm test/test_auth.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}