summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/tp/Manifest1
-rw-r--r--app-emacs/tp/metadata.xml14
-rw-r--r--app-emacs/tp/tp-0.4.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/tp/Manifest b/app-emacs/tp/Manifest
new file mode 100644
index 000000000000..de504ca973c6
--- /dev/null
+++ b/app-emacs/tp/Manifest
@@ -0,0 +1 @@
+DIST tp-0.4.tar.gz 18150 BLAKE2B 78190c82ddd48d739bafecf15efdeba6ed9e6cebac66a08cf131ebb93b5ea8a8e6f3cbaf52a52092e305b0854e9932b98086204e04d0df17d4d550bda0d588be SHA512 b42a905b7892a2e7a0d18a902894e3f400f47983537a82f6f7336bad631763eed7bcff428f5ad0f52b0c0518e2ad2f817a9e954c93a50a1af203465ad5a509df
diff --git a/app-emacs/tp/metadata.xml b/app-emacs/tp/metadata.xml
new file mode 100644
index 000000000000..a44caa852c56
--- /dev/null
+++ b/app-emacs/tp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://codeberg.org/martianh/tp.el/releases/</changelog>
+ <bugs-to>https://codeberg.org/martianh/tp.el/issues/</bugs-to>
+ <remote-id type="codeberg">martianh/tp.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/tp/tp-0.4.ebuild b/app-emacs/tp/tp-0.4.ebuild
new file mode 100644
index 000000000000..1ba163107a3a
--- /dev/null
+++ b/app-emacs/tp/tp-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="28.1"
+
+inherit elisp
+
+DESCRIPTION="Utilities to create transient menus for POSTing to an API for GNU Emacs"
+HOMEPAGE="https://codeberg.org/martianh/tp.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/${PN}.el.git"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/transient
+ || (
+ >=app-editors/emacs-31.0
+ >=app-editors/emacs-${NEED_EMACS}[json]
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( readme.org )
+SITEFILE="50${PN}-gentoo.el"