summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch20
-rw-r--r--dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch29
-rw-r--r--dev-libs/libnatspec/libnatspec-0.3.0.ebuild27
3 files changed, 65 insertions, 11 deletions
diff --git a/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch b/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch
new file mode 100644
index 000000000000..cf775e7c644e
--- /dev/null
+++ b/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@
+ dnl Checks for libraries.
+ check_popt=""
+ AC_CHECK_LIB([popt], [main], check_popt=true)
+-if test "x$check_popt" == x ; then
++if test "x$check_popt" = x ; then
+ AC_MSG_WARN([ libpopt not found.])
+ else
+ POPT_LIBS=-lpopt
+@@ -47,7 +47,7 @@
+
+ check_iconv=""
+ AC_CHECK_HEADERS([iconv.h],check_iconv=true)
+-if test "x$check_iconv" == x ; then
++if test "x$check_iconv" = x ; then
+ AC_MSG_ERROR([*** iconv.h not found.])
+ fi
+ AC_CHECK_LIB([iconv], libiconv_open)
diff --git a/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch b/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch
new file mode 100644
index 000000000000..cb7c542088ed
--- /dev/null
+++ b/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch
@@ -0,0 +1,29 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -54,13 +54,10 @@
+
+ # check Doxygen
+ DOXYGEN=""
+-AC_ARG_WITH(doxygen, [ --with-doxygen Generate doxygen documentation ],
+-[AC_CHECK_PROG(DOX, doxygen, yes)
+-if test "x$DOX" != x ; then
+- DOXYGEN="doxygen"
+-else
+- AC_MSG_ERROR([*** Doxygen not found])
+-fi
++AC_ARG_WITH(doxygen, [ --with-doxygen Generate doxygen documentation ])
++AS_IF([test "x$with_doxygen" = "xyes"], [
++ AC_CHECK_PROG(DOX, doxygen, yes)
++ DOXYGEN="doxygen"
+ ])
+ AC_SUBST(DOXYGEN)
+ AM_CONDITIONAL(HAVE_DOXYGEN, test x$DOXYGEN != x)
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -19,5 +19,4 @@
+
+
+ # install
+-docdir = $(datadir)/doc/@PACKAGE@-@VERSION@/html
+-doc_DATA = $(shell find $(top_srcdir)/docs/html -name \*.*)
++html_DATA = $(shell find $(top_srcdir)/docs/html -name \*.*)
diff --git a/dev-libs/libnatspec/libnatspec-0.3.0.ebuild b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
index 02722757df79..958d7b084fb2 100644
--- a/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
+++ b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -14,25 +14,30 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
IUSE="doc"
-RDEPEND="
- dev-libs/popt
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${PN}-0.2.6-iconv.patch
+ "${FILESDIR}"/${PN}-0.3.0-bashisms.patch
+ "${FILESDIR}"/${PN}-0.3.0-doxygen.patch
)
src_prepare() {
default
- # regenerate to fix imcompatible readlink usage
- rm -f "${S}"/ltmain.sh "${S}"/libtool || die
+ # regenerate to fix incompatible readlink usage
eautoreconf
}
src_configure() {
- use doc || export ac_cv_prog_DOX=no
# braindead configure script does not disable python on --without-python
- econf
+ econf $(use_with doc doxygen)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}