summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-tools/Manifest2
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.1.3.ebuild144
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.1.5.ebuild144
3 files changed, 0 insertions, 290 deletions
diff --git a/media-sound/alsa-tools/Manifest b/media-sound/alsa-tools/Manifest
index eb058b4c6ec4..1b6e5968a3ef 100644
--- a/media-sound/alsa-tools/Manifest
+++ b/media-sound/alsa-tools/Manifest
@@ -1,5 +1,3 @@
DIST alsa-tools-1.1.0.tar.bz2 1715113 BLAKE2B 9b64f3a78e0cff212663c716c189591cd249e58992e5b403e8948b0fa81c4b3b86cc4872f4dcb7a0fadf9cb313043201549b10f3a36d546911bba18fe9fc3602 SHA512 caabbc9a8b494de6bba0dea6440b335b35e5c7dab4942ac36f127a75c2212ff98e7e38566444666edcf40c6c95e6d9797c421014fb5c5c292bb398780e6c9f87
-DIST alsa-tools-1.1.3.tar.bz2 1715759 BLAKE2B c267c746b1b6e986d65e4f69874eb8432e141e823112037ac21f6c794275c818d66dc8adb680c62eb72621d6d6b0974efaffadcf5b7dd7aea53c4c1528631c14 SHA512 b7c6c7639ea30fd8385c817fcd9dee4e5ed7c5766801d11a61d94f3211db4f99ecc0f00173573b69724ad9a06138605c353f4a40c8631eb4325b9718788bea50
-DIST alsa-tools-1.1.5.tar.bz2 1715977 BLAKE2B a8608d19794f7072959121a5f6ab8a7f676d600706bcf52d7e0ec770947fa85948927c1967d4ed35befd31f3bf1b66633ae107274b11490b4bb4558d434c4f80 SHA512 42463540def2260bda0fdb0b08a665ef336deb817920605ce8f77b4904595eadc7d4774d799385bb2271026e26976cc733a776b228814d2c7d7651c46a45098d
DIST alsa-tools-1.1.6.tar.bz2 1778330 BLAKE2B 256ffaef47f78c07f1d8cd86df57b2f75cb6838c407586b52144963350d51271fb500e627e152d05d1c586c337c70fc839072094e0492a0a1b160d6876ccedeb SHA512 33617ec6726ca11f66849c893a8dd9bf9faa8832374788819d9280159ac358c83443331faac24881df593cfd0b24b22769a41cbcb0af3c1fd781baab0c802d17
DIST alsa-tools-1.1.7.tar.bz2 1782642 BLAKE2B 1b2235c3471595c17836b376e5c87194b798f39d2ab52398c634b430c55a4d10482af2aef9568c6694ac4f5a58c4b2f4601cc6a7a80b4e1a3e87dd8d86d8e67a SHA512 d715fa5b909fb33ffce252b4ae9f027dc7c1a509253d52bda6ecbc5e0a38e7d30ab8486b14114b226424217812a0edf66e7ec11f7674e44c77a14e4dfb16889c
diff --git a/media-sound/alsa-tools/alsa-tools-1.1.3.ebuild b/media-sound/alsa-tools/alsa-tools-1.1.3.ebuild
deleted file mode 100644
index 972e14d4b033..000000000000
--- a/media-sound/alsa-tools/alsa-tools-1.1.3.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="https://alsa-project.org/"
-SRC_URI="mirror://alsaproject/tools/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.9"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="fltk gtk alsa_cards_hdsp alsa_cards_hdspm alsa_cards_mixart
-alsa_cards_vx222 alsa_cards_usb-usx2y alsa_cards_sb16 alsa_cards_sbawe
-alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ice1712
-alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sscape alsa_cards_pcxhr"
-
-COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
- >=dev-python/pyalsa-1.0.26
- fltk? ( >=x11-libs/fltk-1.3.0:1 )
- gtk? (
- >=dev-python/pygtk-2
- x11-libs/gtk+:2
- x11-libs/gtk+:3
- )" #468294
-RDEPEND="${COMMON_DEPEND}
- gtk? ( media-fonts/font-misc-misc )" #456114
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/envy24control-config-dir.patch
-)
-
-pkg_setup() {
- ALSA_TOOLS="seq/sbiload us428control hwmixvolume hda-verb"
-
- if use gtk; then
- ALSA_TOOLS="${ALSA_TOOLS} hdajackretask"
- use alsa_cards_ice1712 && \
- ALSA_TOOLS="${ALSA_TOOLS} envy24control"
- use alsa_cards_rme32 && use alsa_cards_rme96 && \
- ALSA_TOOLS="${ALSA_TOOLS} rmedigicontrol"
- fi
-
- if use alsa_cards_hdsp || use alsa_cards_hdspm; then
- ALSA_TOOLS="${ALSA_TOOLS} hdsploader"
- use fltk && ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
- fi
-
- use alsa_cards_mixart && ALSA_TOOLS="${ALSA_TOOLS} mixartloader"
- use alsa_cards_vx222 && ALSA_TOOLS="${ALSA_TOOLS} vxloader"
- use alsa_cards_usb-usx2y && ALSA_TOOLS="${ALSA_TOOLS} usx2yloader"
- use alsa_cards_pcxhr && ALSA_TOOLS="${ALSA_TOOLS} pcxhr"
- use alsa_cards_sscape && ALSA_TOOLS="${ALSA_TOOLS} sscape_ctl"
-
- { use alsa_cards_sb16 || use alsa_cards_sbawe; } && \
- ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
-
- if use alsa_cards_emu10k1 || use alsa_cards_emu10k1x; then
- ALSA_TOOLS="${ALSA_TOOLS} as10k1 ld10k1"
- fi
-
- use gtk && ALSA_TOOLS="${ALSA_TOOLS} echomixer"
-}
-
-src_prepare() {
- default
-
- # This block only deals with the tools that still use GTK and the
- # AM_PATH_GTK macro.
- for dir in echomixer envy24control rmedigicontrol; do
- has "${dir}" "${ALSA_TOOLS}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- # This block deals with the tools that are being patched
- for dir in hdspconf; do
- has "${dir}" "${ALSA_TOOLS}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- elibtoolize
-}
-
-src_configure() {
- if use fltk; then
- # hdspmixer requires fltk
- append-ldflags "-L$(dirname $(fltk-config --libs))"
- append-flags "-I$(fltk-config --includedir)"
- fi
-
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- case "${f}" in
- echomixer,envy24control,rmedigicontrol )
- econf --with-gtk2
- ;;
- * )
- econf
- ;;
- esac
- done
-}
-
-src_compile() {
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- emake
- done
-}
-
-src_install() {
- local f
- for f in ${ALSA_TOOLS}
- do
- # Install the main stuff
- cd "${S}/${f}"
- # hotplugdir is for usx2yloader/Makefile.am
- emake DESTDIR="${D}" hotplugdir=/lib/firmware install
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog AUTHORS; do
- if [[ -f "${doc}" ]]; then
- mv "${doc}" "${doc}.$(basename ${f})" || die
- dodoc "${doc}.$(basename ${f})"
- fi
- done
- done
-
- # Punt at least /usr/lib/liblo10k1.la (last checked, 1.0.27)
- prune_libtool_files
-}
diff --git a/media-sound/alsa-tools/alsa-tools-1.1.5.ebuild b/media-sound/alsa-tools/alsa-tools-1.1.5.ebuild
deleted file mode 100644
index 972e14d4b033..000000000000
--- a/media-sound/alsa-tools/alsa-tools-1.1.5.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="https://alsa-project.org/"
-SRC_URI="mirror://alsaproject/tools/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.9"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="fltk gtk alsa_cards_hdsp alsa_cards_hdspm alsa_cards_mixart
-alsa_cards_vx222 alsa_cards_usb-usx2y alsa_cards_sb16 alsa_cards_sbawe
-alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ice1712
-alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sscape alsa_cards_pcxhr"
-
-COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
- >=dev-python/pyalsa-1.0.26
- fltk? ( >=x11-libs/fltk-1.3.0:1 )
- gtk? (
- >=dev-python/pygtk-2
- x11-libs/gtk+:2
- x11-libs/gtk+:3
- )" #468294
-RDEPEND="${COMMON_DEPEND}
- gtk? ( media-fonts/font-misc-misc )" #456114
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/envy24control-config-dir.patch
-)
-
-pkg_setup() {
- ALSA_TOOLS="seq/sbiload us428control hwmixvolume hda-verb"
-
- if use gtk; then
- ALSA_TOOLS="${ALSA_TOOLS} hdajackretask"
- use alsa_cards_ice1712 && \
- ALSA_TOOLS="${ALSA_TOOLS} envy24control"
- use alsa_cards_rme32 && use alsa_cards_rme96 && \
- ALSA_TOOLS="${ALSA_TOOLS} rmedigicontrol"
- fi
-
- if use alsa_cards_hdsp || use alsa_cards_hdspm; then
- ALSA_TOOLS="${ALSA_TOOLS} hdsploader"
- use fltk && ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
- fi
-
- use alsa_cards_mixart && ALSA_TOOLS="${ALSA_TOOLS} mixartloader"
- use alsa_cards_vx222 && ALSA_TOOLS="${ALSA_TOOLS} vxloader"
- use alsa_cards_usb-usx2y && ALSA_TOOLS="${ALSA_TOOLS} usx2yloader"
- use alsa_cards_pcxhr && ALSA_TOOLS="${ALSA_TOOLS} pcxhr"
- use alsa_cards_sscape && ALSA_TOOLS="${ALSA_TOOLS} sscape_ctl"
-
- { use alsa_cards_sb16 || use alsa_cards_sbawe; } && \
- ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
-
- if use alsa_cards_emu10k1 || use alsa_cards_emu10k1x; then
- ALSA_TOOLS="${ALSA_TOOLS} as10k1 ld10k1"
- fi
-
- use gtk && ALSA_TOOLS="${ALSA_TOOLS} echomixer"
-}
-
-src_prepare() {
- default
-
- # This block only deals with the tools that still use GTK and the
- # AM_PATH_GTK macro.
- for dir in echomixer envy24control rmedigicontrol; do
- has "${dir}" "${ALSA_TOOLS}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- # This block deals with the tools that are being patched
- for dir in hdspconf; do
- has "${dir}" "${ALSA_TOOLS}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- elibtoolize
-}
-
-src_configure() {
- if use fltk; then
- # hdspmixer requires fltk
- append-ldflags "-L$(dirname $(fltk-config --libs))"
- append-flags "-I$(fltk-config --includedir)"
- fi
-
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- case "${f}" in
- echomixer,envy24control,rmedigicontrol )
- econf --with-gtk2
- ;;
- * )
- econf
- ;;
- esac
- done
-}
-
-src_compile() {
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- emake
- done
-}
-
-src_install() {
- local f
- for f in ${ALSA_TOOLS}
- do
- # Install the main stuff
- cd "${S}/${f}"
- # hotplugdir is for usx2yloader/Makefile.am
- emake DESTDIR="${D}" hotplugdir=/lib/firmware install
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog AUTHORS; do
- if [[ -f "${doc}" ]]; then
- mv "${doc}" "${doc}.$(basename ${f})" || die
- dodoc "${doc}.$(basename ${f})"
- fi
- done
- done
-
- # Punt at least /usr/lib/liblo10k1.la (last checked, 1.0.27)
- prune_libtool_files
-}