summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.3.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index a6802f368b17..89c16aef4451 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-1.3.3.gh.tar.gz 936700 BLAKE2B 45e974949dfeaf6487dd76ef13a1b7f4456e805e50d85d089a366c5dc4ac852ccc117224ce5f17affa1f1ba1950a86b6f666cbc8e76edf51bf21cf2f527b877f SHA512 5634b8af997a082031ad1ec12eb83498949f1a56be3a324137d118f55ee51758af8c129da30138fa54f165eafed1572fb2289476e6d0cd838a884ee9118fd8da
+DIST yappi-1.3.5.gh.tar.gz 936884 BLAKE2B a33ea0c506b3e0d05e141b01ebf4af158c6c794c0c504e52c19c00295f105cfff8a6aa8964ce07e13b87cd60164adfd1107da2c286e17dc0d779e7f9e916fbf8 SHA512 2fc243522414626ed6327b3f6b26c4001f01e288700df62cef81e73cf4077af238836b100167df3c4cfb4e0091d4de14385d349b9821759401cc3666e6fe94e9
diff --git a/dev-python/yappi/yappi-1.3.5.ebuild b/dev-python/yappi/yappi-1.3.5.ebuild
new file mode 100644
index 000000000000..699a13380131
--- /dev/null
+++ b/dev-python/yappi/yappi-1.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}