summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/akonadiconsole/Manifest1
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-24.08.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/akonadiconsole/Manifest b/kde-apps/akonadiconsole/Manifest
index ec24bf9cad9f..add9c9960215 100644
--- a/kde-apps/akonadiconsole/Manifest
+++ b/kde-apps/akonadiconsole/Manifest
@@ -1,3 +1,4 @@
DIST akonadiconsole-23.08.5.tar.xz 286164 BLAKE2B d98b053e0626272579196b8ba762b51f0734a7a6d40bb7e7fc71fb2752ed986af95e49317eb59159200dab996aa6c53ac2c18532cda378feeee0cf8f47d9e2a2 SHA512 79071e18b0aed574c67b96cdcdc1ce3914ad67fc1e7e87dc77f9cd6396b210034cdc917393fadb918b90ad89bb2326586002fcf711e0432991e59d05bfde8a06
DIST akonadiconsole-24.05.2.tar.xz 303268 BLAKE2B d0737fcb014b16a0fe3098b5bf7997d44546b64d6d1d2688527c2aa1ef9938ca64ab9259715a488d2bfa6ec548a3a588f7439c38aff6693053b7c5d0aa24e530 SHA512 1dd4ac9975fc9ce16414661d9fdf1d94c92a823ef5ba4ffabb3e12d53f90cb42b2295dc9bb831be1b3600822a112e980f689f201a387a839abecc510b5f4c813
DIST akonadiconsole-24.08.0.tar.xz 304416 BLAKE2B 170f789c8d7d518163abd4fd002b0931f5534d0ad79f1af6f437226c74b399d58a1ac34816a317437239effc7fcd805b6b542a59ed3fa00cc076b59efe8343f8 SHA512 7d87487dfc7c698c451a1eac467573a4e67d554d35ebe7c4644fe85adbed1bfccb53d2ad7d28749b246c9f8000527bccd97bc4559d05e427dcd16121efe17c46
+DIST akonadiconsole-24.08.1.tar.xz 304420 BLAKE2B 7c8d5ac3c0f0c28ebb3999e3755779eb6f88268cb37615ace9907d81aeb794dcf4cd4bce45d6c9f0d7234f513c692160213e41bb64cc29617e0283409ba6c512 SHA512 4eeb526f6c948819cc457b6281f4e6bc04ae69a794a11613c504465bfc71adc6d24f2e3f8b69ce5d319b499eccfd5519fad61b8914a7761935541a68e044f89f
diff --git a/kde-apps/akonadiconsole/akonadiconsole-24.08.1.ebuild b/kde-apps/akonadiconsole/akonadiconsole-24.08.1.ebuild
new file mode 100644
index 000000000000..250da3df197b
--- /dev/null
+++ b/kde-apps/akonadiconsole/akonadiconsole-24.08.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Application for debugging Akonadi Resources"
+HOMEPAGE="https://techbase.kde.org/KDE_PIM/Akonadi/Development_Tools"
+
+LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND="
+ dev-libs/xapian:=
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,sql,widgets]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-mime-${PVCUT}:6
+ >=kde-apps/akonadi-search-${PVCUT}:6
+ >=kde-apps/calendarsupport-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/libkdepim-${PVCUT}:6
+ >=kde-apps/messagelib-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"