summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.0.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-3.0.0.ebuild b/dev-php/pecl-redis/pecl-redis-3.0.0.ebuild
index 7fe79dd26d6e..fe9fd03dae61 100644
--- a/dev-php/pecl-redis/pecl-redis-3.0.0.ebuild
+++ b/dev-php/pecl-redis/pecl-redis-3.0.0.ebuild
@@ -39,3 +39,12 @@ src_install() {
php-ext-pecl-r2_src_install
fi
}
+
+src_test(){
+ local slot
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so tests/TestRedis.php --class Redis --host ${PECL_REDIS_HOST} || die
+ done
+}