summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index a1021143081b..87543edd7a06 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -2,7 +2,5 @@ DIST gitlab-runner-16.2.0-deps.tar.xz 200381264 BLAKE2B 61a9d094c251f299e9871888
DIST gitlab-runner-16.2.0.tar.bz2 1361100 BLAKE2B 19df94ba47188ad696f79df56595f34a2fa7c82971549172a8acc65dd04228aed077d675f85e35e8731ae4b1e72003333ebe667772dce66e6bb17a0ad84a522b SHA512 75097c09b065c8486a5d23219dcb8e36c2baac254e0b09811dd725cf493d959d9b2d3a2c9c130d208a50c1355e19faa749a6d5bb58e1681f782279eca277605e
DIST gitlab-runner-16.3.3-deps.tar.xz 200547520 BLAKE2B 432ed7485f66ccd809e6bfbb7e6578fe10d6ef65843549d4fdccd85da2680b2f2b33b5dee829d926a237577996ba77fbd61b9d62e7db439fea47b8577b5c4dbd SHA512 a67a522c7109550e354dd892dc3bfedf73604128fe6d4a865d9dad1bc97dca2f8ae10eb8c85c225ddf9e6ebd285d266fdd26e73588ce72cbf372e2ed53c8cf07
DIST gitlab-runner-16.3.3.tar.bz2 1367409 BLAKE2B f74556c945fef53d490be2159b62e0ac663e6f71b3cf45bf6002f7c12ec250bff6ed20a3787f2d154dfe01b4dc082caf4650cdfc24002da9742518bf1238717a SHA512 184c616efff930922a33e1c0debd46cc720b355820279f370fe4827e9534c9c1956bb4e2d77489ab773b6a1da985fe2bbf7192c99ba8c39a47997fd3184557da
-DIST gitlab-runner-16.4.1-deps.tar.xz 218819612 BLAKE2B 5f8e69d4ea8e99b86c123bb97a2ff093b0efc453cf711e36e0596987c05cba01c77190fc3777157d4f587e7f99a63ec5f48265bfea8f176c81d4ad7c907b1bcc SHA512 a9e726cbb6a7e31d4d8ddcc67c25eba4d2dd6631413693ab7b7df3a9ac66aa1f9dcc2fca3c95e685b259e409dbeb22b41b89efee292b8d8f95f75b398a16b9aa
-DIST gitlab-runner-16.4.1.tar.bz2 1371697 BLAKE2B d1b3b5636e764afa9a619dc9f6af66d4e0edf6e6e0d4e81c78d9b093f86101fe4421e646f264f5776070afbacef8f93de8f4cfbb65360b827ecf68d4d41359f7 SHA512 e12b2cea44295151b9783800837367e61e769d95012c7b3d633a23bd93b85db2f61ffbe4e04b9dcac7a7caabb6511ea956f880774aceeeea36236b11c36d56d3
DIST gitlab-runner-16.4.2-deps.tar.xz 218831500 BLAKE2B e639c446aafd9095e07a6dd64b50e99035b42a9b16caec081ff9fc449df81b044afd57819bc320fcf050ff2b25be8d70aa56def7fdae29676f946b145a9b25a1 SHA512 28480ca7bf6b0c8abf655181530464baabc706513d5dd5bb0c58a6b2bc70ce4190eee3d568873e44fc256e523b27ef28f38af0ff16aa1f8f5b1828c44895d722
DIST gitlab-runner-16.4.2.tar.bz2 1371196 BLAKE2B 9ff9073fa69a4a04b59d9e3274eec9c86817fd198f3b3ab877352869eb5d5bb0f1aab69fd9500d9f87ac3ca4def9b6d286d82905be4e48014fa902f29dc9c6b5 SHA512 59817206b4d654ec27512fd0713d7d2a879ca4cd6e1abe46e0314c90db49795316f8b6d196f9b5bf11d9ff04efd16f8d580131a39ac20cc21ed4c3bc83e9d5b9
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild
deleted file mode 100644
index a181955c5c1b..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=d89a789a
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}