summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/pkgconf/pkgconf-1.7.3-r1.ebuild (renamed from dev-util/pkgconf/pkgconf-1.7.3.ebuild)13
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild13
-rw-r--r--eclass/multilib.eclass5
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild15
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild15
-rw-r--r--net-misc/minidlna/files/minidlna-1.2.1-fno-common.patch45
-rw-r--r--net-misc/minidlna/minidlna-1.2.1-r1.ebuild4
-rw-r--r--sys-block/cec/cec-14.ebuild7
-rw-r--r--sys-block/cec/files/cec-14-fno-common.patch57
-rw-r--r--x11-misc/spacefm/files/spacefm-fno-common.patch86
-rw-r--r--x11-misc/spacefm/metadata.xml2
-rw-r--r--x11-misc/spacefm/spacefm-1.0.6-r1.ebuild68
-rw-r--r--x11-misc/spacefm/spacefm-1.0.6.ebuild88
-rw-r--r--x11-misc/spacefm/spacefm-9999.ebuild60
-rw-r--r--x11-plugins/purple-libnotify-plus/files/purple-libnotify-plus-2.99.1-fno-common.patch11
-rw-r--r--x11-plugins/purple-libnotify-plus/purple-libnotify-plus-2.99.1.ebuild13
16 files changed, 343 insertions, 159 deletions
diff --git a/dev-util/pkgconf/pkgconf-1.7.3.ebuild b/dev-util/pkgconf/pkgconf-1.7.3-r1.ebuild
index a801ef026bff..858af22520ed 100644
--- a/dev-util/pkgconf/pkgconf-1.7.3.ebuild
+++ b/dev-util/pkgconf/pkgconf-1.7.3-r1.ebuild
@@ -30,11 +30,7 @@ BDEPEND="
)
"
RDEPEND="
- pkg-config? (
- !dev-util/pkgconfig
- !dev-util/pkg-config-lite
- !dev-util/pkgconfig-openbsd[pkg-config]
- )
+ pkg-config? ( !dev-util/pkgconfig )
"
MULTILIB_CHOST_TOOLS=(
@@ -54,7 +50,12 @@ src_prepare() {
multilib_src_configure() {
local ECONF_SOURCE="${S}"
- econf --disable-static
+ local args=(
+ --disable-static
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+ econf "${args[@]}"
}
multilib_src_test() {
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 40e4e28319d4..a29e166995b7 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -30,11 +30,7 @@ BDEPEND="
)
"
RDEPEND="
- pkg-config? (
- !dev-util/pkgconfig
- !dev-util/pkg-config-lite
- !dev-util/pkgconfig-openbsd[pkg-config]
- )
+ pkg-config? ( !dev-util/pkgconfig )
"
MULTILIB_CHOST_TOOLS=(
@@ -54,7 +50,12 @@ src_prepare() {
multilib_src_configure() {
local ECONF_SOURCE="${S}"
- econf --disable-static
+ local args=(
+ --disable-static
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+ econf "${args[@]}"
}
multilib_src_test() {
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index 9c7042fcd299..095e3a4f4508 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -3,7 +3,6 @@
# @ECLASS: multilib.eclass
# @MAINTAINER:
-# amd64@gentoo.org
# toolchain@gentoo.org
# @BLURB: This eclass is for all functions pertaining to handling multilib configurations.
# @DESCRIPTION:
@@ -498,6 +497,7 @@ multilib_toolchain_setup() {
STRIP
PKG_CONFIG_LIBDIR
PKG_CONFIG_PATH
+ PKG_CONFIG_SYSTEM_INCLUDE_PATH
PKG_CONFIG_SYSTEM_LIBRARY_PATH
)
@@ -547,7 +547,8 @@ multilib_toolchain_setup() {
export CHOST=$(get_abi_CHOST $1)
export PKG_CONFIG_LIBDIR=${EPREFIX}/usr/$(get_libdir)/pkgconfig
export PKG_CONFIG_PATH=${EPREFIX}/usr/share/pkgconfig
- export PKG_CONFIG_SYSTEM_LIBRARY_PATH=${EPREFIX}/usr/$(get_libdir)
+ export PKG_CONFIG_SYSTEM_INCLUDE_PATH=${EPREFIX}/usr/include
+ export PKG_CONFIG_SYSTEM_LIBRARY_PATH=${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)
fi
}
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
index c7003379c001..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${WORKDIR}/${P}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
index 3c26883fb122..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${S}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}
diff --git a/net-misc/minidlna/files/minidlna-1.2.1-fno-common.patch b/net-misc/minidlna/files/minidlna-1.2.1-fno-common.patch
new file mode 100644
index 000000000000..5cca89b52db2
--- /dev/null
+++ b/net-misc/minidlna/files/minidlna-1.2.1-fno-common.patch
@@ -0,0 +1,45 @@
+--- a/image_utils.c
++++ b/image_utils.c
+@@ -190,7 +190,7 @@ jpeg_memory_src(j_decompress_ptr cinfo, const unsigned char * buffer, size_t buf
+ src->pub.bytes_in_buffer = bufsize;
+ }
+
+-jmp_buf setjmp_buffer;
++static jmp_buf setjmp_buffer;
+ /* Don't exit on error like libjpeg likes to do */
+ static void
+ libjpeg_error_handler(j_common_ptr cinfo)
+--- a/metadata.c
++++ b/metadata.c
+@@ -484,7 +484,7 @@ GetAudioMetadata(const char *path, const char *name)
+ }
+
+ /* For libjpeg error handling */
+-jmp_buf setjmp_buffer;
++static jmp_buf setjmp_buffer;
+ static void
+ libjpeg_error_handler(j_common_ptr cinfo)
+ {
+--- a/tivo_utils.c
++++ b/tivo_utils.c
+@@ -27,6 +27,7 @@
+ #include <sqlite3.h>
+ #include "tivo_utils.h"
+
++struct sqlite3PrngType sqlite3Prng;
+ /* This function based on byRequest */
+ char *
+ decodeString(char *string, int inplace)
+--- a/tivo_utils.h
++++ b/tivo_utils.h
+@@ -30,7 +30,9 @@ struct sqlite3PrngType {
+ unsigned char isInit; /* True if initialized */
+ unsigned char i, j; /* State variables */
+ unsigned char s[256]; /* State variables */
+-} sqlite3Prng;
++};
++
++extern struct sqlite3PrngType sqlite3Prng;
+
+ char *
+ decodeString(char *string, int inplace);
diff --git a/net-misc/minidlna/minidlna-1.2.1-r1.ebuild b/net-misc/minidlna/minidlna-1.2.1-r1.ebuild
index 47ee6484cd27..9d6ba5c94f4b 100644
--- a/net-misc/minidlna/minidlna-1.2.1-r1.ebuild
+++ b/net-misc/minidlna/minidlna-1.2.1-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="amd64 arm x86"
-IUSE="netgear readynas zeroconf"
+IUSE="elibc_musl netgear readynas zeroconf"
RDEPEND="dev-db/sqlite:3
media-libs/flac:=
@@ -24,6 +24,7 @@ RDEPEND="dev-db/sqlite:3
media-libs/libvorbis:=
media-video/ffmpeg:0=
virtual/jpeg:0=
+ elibc_musl? ( sys-libs/queue-standalone )
zeroconf? ( net-dns/avahi:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -32,6 +33,7 @@ CONFIG_CHECK="~INOTIFY_USER"
PATCHES=(
"${WORKDIR}"/minidlna-gentoo-artwork.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
diff --git a/sys-block/cec/cec-14.ebuild b/sys-block/cec/cec-14.ebuild
index 1b70ba738da6..367dcfda642f 100644
--- a/sys-block/cec/cec-14.ebuild
+++ b/sys-block/cec/cec-14.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,8 @@ SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
diff --git a/sys-block/cec/files/cec-14-fno-common.patch b/sys-block/cec/files/cec-14-fno-common.patch
new file mode 100644
index 000000000000..e7e3ce022675
--- /dev/null
+++ b/sys-block/cec/files/cec-14-fno-common.patch
@@ -0,0 +1,57 @@
+--- a/cec.c
++++ b/cec.c
+@@ -20,6 +20,9 @@
+ typedef struct Shelf Shelf;
+ typedef struct Pkt Pkt;
+
++int debug;
++char *progname;
++
+ struct Pkt {
+ uchar dst[6];
+ uchar src[6];
+@@ -76,7 +79,7 @@ extern int errno;
+ Shelf tab[Ntab];
+ int ntab;
+ uchar contag;
+-extern int fd; /* set in netopen */
++int fd; /* set in netopen */
+ int shelf;
+ Shelf *connp;
+ char esc = '';
+--- a/cec.h
++++ b/cec.h
+@@ -6,8 +6,8 @@ typedef unsigned char uchar;
+ typedef unsigned int uint;
+ #endif
+
+-int debug;
+-char *progname;
++extern int debug;
++extern char *progname;
+ extern char hbacecfile[];
+
+ int netopen(char *name);
+--- a/hba.c
++++ b/hba.c
+@@ -9,7 +9,7 @@
+
+ #include "cec.h"
+
+-int fd;
++extern int fd;
+ static char hba_bytes[1<<14];
+ static int hba_len;
+
+--- a/linux.c
++++ b/linux.c
+@@ -25,7 +25,8 @@
+
+ #include "cec.h"
+
+-int fd;
++extern int fd;
++extern int debug;
+ char net_bytes[1<<14];
+ int net_len;
+ char srcaddr[6];
diff --git a/x11-misc/spacefm/files/spacefm-fno-common.patch b/x11-misc/spacefm/files/spacefm-fno-common.patch
new file mode 100644
index 000000000000..4cdc834a8277
--- /dev/null
+++ b/x11-misc/spacefm/files/spacefm-fno-common.patch
@@ -0,0 +1,86 @@
+--- a/src/settings.c
++++ b/src/settings.c
+@@ -52,6 +52,24 @@
+ /* Dirty hack: check whether we are under LXDE or not */
+ #define is_under_LXDE() (g_getenv( "_LXSESSION_PID" ) != NULL)
+
++char* settings_terminal_su = NULL;
++char* settings_graphical_su = NULL;
++GList* xset_cmd_history = NULL;
++XSet* evt_win_focus = NULL;
++XSet* evt_win_move = NULL;
++XSet* evt_win_click = NULL;
++XSet* evt_win_key = NULL;
++XSet* evt_win_close = NULL;
++XSet* evt_pnl_show = NULL;
++XSet* evt_pnl_focus = NULL;
++XSet* evt_pnl_sel = NULL;
++XSet* evt_tab_new = NULL;
++XSet* evt_tab_chdir = NULL;
++XSet* evt_tab_focus = NULL;
++XSet* evt_tab_close = NULL;
++XSet* evt_device = NULL;
++
++
+ AppSettings app_settings = {0};
+ /* const gboolean singleInstance_default = TRUE; */
+ const gboolean show_hidden_files_default = FALSE;
+--- a/src/settings.h
++++ b/src/settings.h
+@@ -120,7 +120,7 @@ const char* xset_get_user_tmp_dir();
+ ///////////////////////////////////////////////////////////////////////////////
+ //MOD extra settings below
+
+-GList* xsets;
++extern GList* xsets;
+
+ enum {
+ XSET_B_UNSET,
+@@ -311,22 +311,22 @@ typedef struct
+ } XMenuItem;
+
+ // cache these for speed in event handlers
+-XSet* evt_win_focus;
+-XSet* evt_win_move;
+-XSet* evt_win_click;
+-XSet* evt_win_key;
+-XSet* evt_win_close;
+-XSet* evt_pnl_show;
+-XSet* evt_pnl_focus;
+-XSet* evt_pnl_sel;
+-XSet* evt_tab_new;
+-XSet* evt_tab_chdir;
+-XSet* evt_tab_focus;
+-XSet* evt_tab_close;
+-XSet* evt_device;
++extern XSet* evt_win_focus;
++extern XSet* evt_win_move;
++extern XSet* evt_win_click;
++extern XSet* evt_win_key;
++extern XSet* evt_win_close;
++extern XSet* evt_pnl_show;
++extern XSet* evt_pnl_focus;
++extern XSet* evt_pnl_sel;
++extern XSet* evt_tab_new;
++extern XSet* evt_tab_chdir;
++extern XSet* evt_tab_focus;
++extern XSet* evt_tab_close;
++extern XSet* evt_device;
+
+ // instance-wide command history
+-GList* xset_cmd_history;
++extern GList* xset_cmd_history;
+
+ static const char* terminal_programs[] = //for pref-dialog.c
+ {
+@@ -374,8 +374,8 @@ static const char* gsu_commands[] = // order and contents must match prefdlg.ui
+ };
+
+ // These will contain the su and gsu settings from /etc/spacefm/spacefm.conf
+-char* settings_terminal_su;
+-char* settings_graphical_su;
++extern char* settings_terminal_su;
++extern char* settings_graphical_su;
+
+ typedef struct
+ {
diff --git a/x11-misc/spacefm/metadata.xml b/x11-misc/spacefm/metadata.xml
index 35fc0bff16f7..f5c9eb81f009 100644
--- a/x11-misc/spacefm/metadata.xml
+++ b/x11-misc/spacefm/metadata.xml
@@ -14,8 +14,6 @@
<remote-id type="github">ignorantguru/spacefm</remote-id>
</upstream>
<use>
- <flag name="gtk2">Support GTK+ 2.x instead of GTK+ 3.x</flag>
- <flag name="gtk3">Support GTK+ 3.x instead of GTK+ 2.x</flag>
<flag name="video-thumbnails">Support video thumbnails with <pkg>media-video/ffmpegthumbnailer</pkg></flag>
</use>
<longdescription lang="en">
diff --git a/x11-misc/spacefm/spacefm-1.0.6-r1.ebuild b/x11-misc/spacefm/spacefm-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..b206e28490ad
--- /dev/null
+++ b/x11-misc/spacefm/spacefm-1.0.6-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info optfeature xdg
+
+DESCRIPTION="A multi-panel tabbed file manager"
+HOMEPAGE="https://ignorantguru.github.com/spacefm/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/IgnorantGuru/${PN}.git"
+ EGIT_BRANCH="next"
+ inherit git-r3
+else
+ KEYWORDS="amd64 x86"
+ SRC_URI="https://github.com/IgnorantGuru/spacefm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+startup-notification +video-thumbnails"
+
+RDEPEND="dev-libs/glib:2
+ dev-util/desktop-file-utils
+ virtual/udev
+ virtual/freedesktop-icon-theme
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-libs/libX11
+ x11-misc/shared-mime-info
+ startup-notification? ( x11-libs/startup-notification )
+ video-thumbnails? ( media-video/ffmpegthumbnailer )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-include-sysmacros.patch
+ "${FILESDIR}"/${PN}-fno-common.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable startup-notification) \
+ $(use_enable video-thumbnails) \
+ --disable-hal \
+ --enable-inotify \
+ --disable-pixmaps \
+ --with-gtk3
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "mounting as non-root user" sys-apps/udevil sys-apps/pmount sys-fs/udisks
+ optfeature "supporting ftp/nfs/smb/ssh URLs in the path bar" sys-apps/udevil
+ optfeature "performing as root" x11-misc/ktsuss kde-plasma/kde-cli-tools[kdesu]
+ optfeature "other optional dependencies" sys-apps/dbus sys-process/lsof virtual/eject
+
+ if ! has_version 'sys-fs/udisks' ; then
+ elog "When using SpaceFM without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See /usr/share/doc/${PF}/html/spacefm-manual-en.html#devices-kernpoll"
+ fi
+}
diff --git a/x11-misc/spacefm/spacefm-1.0.6.ebuild b/x11-misc/spacefm/spacefm-1.0.6.ebuild
deleted file mode 100644
index f1c2cea9d53c..000000000000
--- a/x11-misc/spacefm/spacefm-1.0.6.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils linux-info xdg-utils
-
-DESCRIPTION="A multi-panel tabbed file manager"
-HOMEPAGE="https://ignorantguru.github.com/spacefm/"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/IgnorantGuru/${PN}.git"
- EGIT_BRANCH="next"
- inherit git-r3
-else
- KEYWORDS="amd64 x86"
- SRC_URI="https://github.com/IgnorantGuru/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="gtk2 +gtk3 +startup-notification +video-thumbnails"
-
-RDEPEND="dev-libs/glib:2
- dev-util/desktop-file-utils
- >=virtual/udev-143
- virtual/freedesktop-icon-theme
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/pango
- x11-libs/libX11
- x11-misc/shared-mime-info
- gtk2? ( gtk3? ( x11-libs/gtk+:3 ) !gtk3? ( x11-libs/gtk+:2 ) )
- !gtk2? ( x11-libs/gtk+:3 )
- startup-notification? ( x11-libs/startup-notification )
- video-thumbnails? ( media-video/ffmpegthumbnailer )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-9999-include-sysmacros.patch )
-
-src_configure() {
- econf \
- $(use_enable startup-notification) \
- $(use_enable video-thumbnails) \
- --disable-hal \
- --enable-inotify \
- --disable-pixmaps \
- $(use_with gtk3 gtk3 "yes")
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-
- einfo
- elog "To mount as non-root user you need one of the following:"
- elog " sys-apps/udevil (recommended, see below)"
- elog " sys-apps/pmount"
- elog " sys-fs/udisks:0"
- elog " sys-fs/udisks:2"
- elog "To support ftp/nfs/smb/ssh URLs in the path bar you need:"
- elog " sys-apps/udevil"
- elog "To perform as root functionality you need one of the following:"
- elog " x11-misc/ktsuss"
- elog " kde-plasma/kde-cli-tools[kdesu]"
- elog "Other optional dependencies:"
- elog " sys-apps/dbus"
- elog " sys-process/lsof (device processes)"
- elog " virtual/eject (eject media)"
- einfo
- if ! has_version 'sys-fs/udisks' ; then
- elog "When using SpaceFM without udisks, and without the udisks-daemon running,"
- elog "you may need to enable kernel polling for device media changes to be detected."
- elog "See /usr/share/doc/${PF}/html/spacefm-manual-en.html#devices-kernpoll"
- has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
- kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
- einfo
- fi
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}
diff --git a/x11-misc/spacefm/spacefm-9999.ebuild b/x11-misc/spacefm/spacefm-9999.ebuild
index 31647a6d0f80..b206e28490ad 100644
--- a/x11-misc/spacefm/spacefm-9999.ebuild
+++ b/x11-misc/spacefm/spacefm-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit gnome2-utils linux-info xdg-utils
+inherit linux-info optfeature xdg
DESCRIPTION="A multi-panel tabbed file manager"
HOMEPAGE="https://ignorantguru.github.com/spacefm/"
@@ -12,33 +12,35 @@ if [[ ${PV} == *9999* ]]; then
EGIT_BRANCH="next"
inherit git-r3
else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/IgnorantGuru/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ SRC_URI="https://github.com/IgnorantGuru/spacefm/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="gtk2 +gtk3 +startup-notification +video-thumbnails"
+IUSE="+startup-notification +video-thumbnails"
RDEPEND="dev-libs/glib:2
dev-util/desktop-file-utils
- >=virtual/udev-143
+ virtual/udev
virtual/freedesktop-icon-theme
x11-libs/cairo
x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
x11-libs/pango
x11-libs/libX11
x11-misc/shared-mime-info
- gtk2? ( gtk3? ( x11-libs/gtk+:3 ) !gtk3? ( x11-libs/gtk+:2 ) )
- !gtk2? ( x11-libs/gtk+:3 )
startup-notification? ( x11-libs/startup-notification )
video-thumbnails? ( media-video/ffmpegthumbnailer )"
-DEPEND="${RDEPEND}
- dev-util/intltool
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${PN}-9999-include-sysmacros.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-include-sysmacros.patch
+ "${FILESDIR}"/${PN}-fno-common.patch
+)
src_configure() {
econf \
@@ -47,42 +49,20 @@ src_configure() {
--disable-hal \
--enable-inotify \
--disable-pixmaps \
- $(use_with gtk3 gtk3 "yes")
+ --with-gtk3
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_pkg_postinst
+
+ optfeature "mounting as non-root user" sys-apps/udevil sys-apps/pmount sys-fs/udisks
+ optfeature "supporting ftp/nfs/smb/ssh URLs in the path bar" sys-apps/udevil
+ optfeature "performing as root" x11-misc/ktsuss kde-plasma/kde-cli-tools[kdesu]
+ optfeature "other optional dependencies" sys-apps/dbus sys-process/lsof virtual/eject
- einfo
- elog "To mount as non-root user you need one of the following:"
- elog " sys-apps/udevil (recommended, see below)"
- elog " sys-apps/pmount"
- elog " sys-fs/udisks:0"
- elog " sys-fs/udisks:2"
- elog "To support ftp/nfs/smb/ssh URLs in the path bar you need:"
- elog " sys-apps/udevil"
- elog "To perform as root functionality you need one of the following:"
- elog " x11-misc/ktsuss"
- elog " kde-plasma/kde-cli-tools[kdesu]"
- elog "Other optional dependencies:"
- elog " sys-apps/dbus"
- elog " sys-process/lsof (device processes)"
- elog " virtual/eject (eject media)"
- einfo
if ! has_version 'sys-fs/udisks' ; then
elog "When using SpaceFM without udisks, and without the udisks-daemon running,"
elog "you may need to enable kernel polling for device media changes to be detected."
elog "See /usr/share/doc/${PF}/html/spacefm-manual-en.html#devices-kernpoll"
- has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
- kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
- einfo
fi
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- gnome2_icon_cache_update
-}
diff --git a/x11-plugins/purple-libnotify-plus/files/purple-libnotify-plus-2.99.1-fno-common.patch b/x11-plugins/purple-libnotify-plus/files/purple-libnotify-plus-2.99.1-fno-common.patch
new file mode 100644
index 000000000000..12d2cdda8de6
--- /dev/null
+++ b/x11-plugins/purple-libnotify-plus/files/purple-libnotify-plus-2.99.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/purple-libnotify+-common.h
++++ b/src/purple-libnotify+-common.h
+@@ -27,7 +27,7 @@
+
+ extern PurplePlugin *notify_plus;
+
+-struct
++extern struct
+ {
+ gboolean modify_notification;
+ gboolean use_svg;
diff --git a/x11-plugins/purple-libnotify-plus/purple-libnotify-plus-2.99.1.ebuild b/x11-plugins/purple-libnotify-plus/purple-libnotify-plus-2.99.1.ebuild
index 5a3198f74a14..54ed903d1c51 100644
--- a/x11-plugins/purple-libnotify-plus/purple-libnotify-plus-2.99.1.ebuild
+++ b/x11-plugins/purple-libnotify-plus/purple-libnotify-plus-2.99.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Provide libnotify interface to Pidgin and Finch"
HOMEPAGE="http://purple-libnotify-plus.sardemff7.net/"
@@ -12,18 +12,21 @@ SRC_URI="https://github.com/sardemff7/purple-libnotify-plus/archive/v${PV}.tar.g
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="
net-im/pidgin
>=net-im/purple-events-0.99.1
x11-libs/gdk-pixbuf
>=x11-libs/libnotify-0.7.0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_prepare() {
+ default
eautoreconf
}