summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/speedtest-cli/metadata.xml4
-rw-r--r--net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/net-analyzer/speedtest-cli/metadata.xml b/net-analyzer/speedtest-cli/metadata.xml
index 3cd6205ee49a..1608948afeb0 100644
--- a/net-analyzer/speedtest-cli/metadata.xml
+++ b/net-analyzer/speedtest-cli/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
<upstream>
<remote-id type="github">sivel/speedtest-cli</remote-id>
</upstream>
diff --git a/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild b/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
index 31f0010ac79e..2a7c8b1f1b68 100644
--- a/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
+++ b/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -14,13 +15,10 @@ SRC_URI="https://github.com/sivel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
-IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-DOCS=( CONTRIBUTING.md README.rst )
-
python_install_all() {
doman ${PN}.1
distutils-r1_python_install_all