summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-27 05:15:38 +0100
committerSam James <sam@gentoo.org>2023-04-27 05:17:18 +0100
commit7d8dc57c3570616a47e7599b3e7692788ac81180 (patch)
tree741709c4ac2cb04d7755083654ffb8d368fcdda5 /xfce-extra
parentnet-libs/nodejs: typo fix for 20.0.0 (diff)
downloadgentoo-7d8dc57c3570616a47e7599b3e7692788ac81180.tar.gz
gentoo-7d8dc57c3570616a47e7599b3e7692788ac81180.tar.bz2
gentoo-7d8dc57c3570616a47e7599b3e7692788ac81180.zip
xfce-extra/xfce4-systemload-plugin: fix build on x86
Closes: https://bugs.gentoo.org/905084 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch22
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild60
2 files changed, 82 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch
new file mode 100644
index 000000000000..027aea406823
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/905084
+https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/-/issues/25
+https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/-/commit/13a2e3ecb4b6cf6aad26c6b1d2388ef6922a5c92
+
+From 13a2e3ecb4b6cf6aad26c6b1d2388ef6922a5c92 Mon Sep 17 00:00:00 2001
+From: Akbarkhon Variskhanov <akbarkhon.variskhanov@gmail.com>
+Date: Tue, 20 Dec 2022 13:50:40 +0500
+Subject: [PATCH] build: Fix failure due to wrong var type (Fixes #25)
+
+--- a/panel-plugin/network.cc
++++ b/panel-plugin/network.cc
+@@ -114,7 +114,7 @@ read_netload_proc (gulong *bytes)
+ gint
+ read_netload (gulong *net, gulong *NTotal)
+ {
+- static guint64 bytes[2];
++ static gulong bytes[2];
+ static gint64 time[2];
+
+ *net = 0;
+--
+GitLab
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..27fc98975a83
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-systemload-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.16:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+ >=xfce-base/xfconf-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-x86.patch
+)
+
+src_configure() {
+ local myconf=(
+ # gtop is needed only as fallback when /proc is not available
+ --disable-libgtop
+ $(use_enable upower)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}