summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorØrjan Malde <red@foxi.me>2022-05-07 05:29:15 +0100
committerSam James <sam@gentoo.org>2022-05-07 19:24:14 +0100
commit5a66829cbc103112561433ebad7507ecd662b3cc (patch)
treef04804561e38d694dfd958749fbbb220f1fb4bc4 /x11-themes
parentsys-devel/slibtool: Fix build with self-hosted clang (diff)
downloadgentoo-5a66829cbc103112561433ebad7507ecd662b3cc.tar.gz
gentoo-5a66829cbc103112561433ebad7507ecd662b3cc.tar.bz2
gentoo-5a66829cbc103112561433ebad7507ecd662b3cc.zip
x11-themes/gtk-engines-unico: fix build with slibtool
Closes: https://bugs.gentoo.org/792435 Signed-off-by: Ørjan Malde <red@foxi.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-unico/files/gtk-engines-unico-1.0.3_pre20140109-slibtool-lm.patch24
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild7
2 files changed, 30 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-unico/files/gtk-engines-unico-1.0.3_pre20140109-slibtool-lm.patch b/x11-themes/gtk-engines-unico/files/gtk-engines-unico-1.0.3_pre20140109-slibtool-lm.patch
new file mode 100644
index 000000000000..2fe92337847a
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/files/gtk-engines-unico-1.0.3_pre20140109-slibtool-lm.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/792435
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -106,6 +106,9 @@
+ GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-3.0`
+ AC_SUBST(GTK_VERSION)
+
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
++
+ # Files
+
+ AC_CONFIG_FILES([
+--- a/unico/Makefile.am
++++ b/unico/Makefile.am
+@@ -20,6 +20,6 @@
+
+ libunico_la_CFLAGS = $(UNICO_CFLAGS)
+
+-libunico_la_LIBADD = $(UNICO_LIBADD)
++libunico_la_LIBADD = $(UNICO_LIBADD) $(LIBM)
+
+ libunico_la_LDFLAGS = $(UNICO_LDFLAGS)
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild
index 2732161394a1..f2c47677c255 100644
--- a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,8 +27,13 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3_pre20140109-slibtool-lm.patch
+)
+
src_prepare() {
default
+
eautoreconf
}