summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChrisOboe <chris@oboe.email>2019-04-07 00:12:03 +0200
committerIan Whyman <thev00d00@gentoo.org>2019-04-07 11:33:07 +0100
commit73b4f7046b4ab4d56a858c8214ae506c8de46077 (patch)
treef9b6d290dd0fdc7e4ab00fc1507ec472da2f9e06 /x11-themes/kvantum
parentmedia-libs/ctl: Fix compat with newer openexr (diff)
downloadgentoo-73b4f7046b4ab4d56a858c8214ae506c8de46077.tar.gz
gentoo-73b4f7046b4ab4d56a858c8214ae506c8de46077.tar.bz2
gentoo-73b4f7046b4ab4d56a858c8214ae506c8de46077.zip
x11-themes/kvantum: added missing dependency Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Chris Oboe <chris@oboe.email> Closes: https://github.com/gentoo/gentoo/pull/11614 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'x11-themes/kvantum')
-rw-r--r--x11-themes/kvantum/kvantum-0.11.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/kvantum/kvantum-0.11.0-r1.ebuild b/x11-themes/kvantum/kvantum-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..36fcd2ca702b
--- /dev/null
+++ b/x11-themes/kvantum/kvantum-0.11.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN="Kvantum"
+
+DESCRIPTION="SVG-based theme engine for Qt4/Qt5, KDE and LXQt"
+HOMEPAGE="https://github.com/tsujan/Kvantum"
+SRC_URI="https://github.com/tsujan/${MY_PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kwindowsystem
+ x11-libs/libXext
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${MY_PN}"