summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2023-12-28 12:01:21 +0400
committerSam James <sam@gentoo.org>2023-12-30 03:01:06 +0000
commit87b0c65fb235692fb1ffc5e7d3e6505bef5d7e7a (patch)
tree0a01205c1904d98aa23a09afb7ac12b31881610e /x11-terms
parentsys-apps/fwts: add 23.11.00 (diff)
downloadgentoo-87b0c65fb235692fb1ffc5e7d3e6505bef5d7e7a.tar.gz
gentoo-87b0c65fb235692fb1ffc5e7d3e6505bef5d7e7a.tar.bz2
gentoo-87b0c65fb235692fb1ffc5e7d3e6505bef5d7e7a.zip
x11-terms/alacritty: cleanup 9999 based on QA
Use `pycargoebuild` to fill the `LICENSE` field. Also drop redundant `.md` files because they serve no value for the users. Python dependency was also dropped because it's not longer used by any of the xcb crates. Signed-off-by: Kirill Chibisov <contact@kchibisov.com> Closes: https://github.com/gentoo/gentoo/pull/34511 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/alacritty/alacritty-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11-terms/alacritty/alacritty-9999.ebuild b/x11-terms/alacritty/alacritty-9999.ebuild
index ea8e284e0fbc..6bdfbfe42e1a 100644
--- a/x11-terms/alacritty/alacritty-9999.ebuild
+++ b/x11-terms/alacritty/alacritty-9999.ebuild
@@ -7,10 +7,8 @@ CRATES="
"
MY_PV="${PV//_rc/-rc}"
-# https://bugs.gentoo.org/725962
-PYTHON_COMPAT=( python3_{9..12} )
-inherit bash-completion-r1 cargo desktop python-any-r1
+inherit bash-completion-r1 cargo desktop
DESCRIPTION="GPU-accelerated terminal emulator"
HOMEPAGE="https://alacritty.org"
@@ -20,11 +18,16 @@ if [ ${PV} == "9999" ] ; then
EGIT_REPO_URI="https://github.com/alacritty/alacritty"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris)"
+ ${CARGO_CRATE_URIS}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
-LICENSE="Apache-2.0 Artistic-2 Boost-1.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB"
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC MIT MPL-2.0
+ Unicode-DFS-2016
+"
SLOT="0"
IUSE="wayland +X"
@@ -39,7 +42,6 @@ COMMON_DEPEND="
DEPEND="
${COMMON_DEPEND}
- ${PYTHON_DEPS}
"
RDEPEND="${COMMON_DEPEND}
@@ -56,7 +58,7 @@ RDEPEND="${COMMON_DEPEND}
BDEPEND="
dev-util/cmake
- >=virtual/rust-1.65.0
+ >=virtual/rust-1.70.0
app-text/scdoc
"
@@ -114,8 +116,7 @@ src_install() {
doins -r scripts/*
local DOCS=(
- CHANGELOG.md INSTALL.md README.md
- docs/{escape_support.md,features.md}
+ CHANGELOG.md README.md
)
einstalldocs
}