summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorend222 <pabloorduna98@gmail.com>2020-03-20 10:59:44 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-20 16:30:42 +0200
commit34a7049bb64b825e8708ec2584551cf68a0a9645 (patch)
tree8832cb0ddbc4decf244286714974c72fac28a9e9 /x11-terms
parentnet-im/signal-desktop-bin: add info about tray icon on Xfce for 1.32.1 (diff)
downloadgentoo-34a7049bb64b825e8708ec2584551cf68a0a9645.tar.gz
gentoo-34a7049bb64b825e8708ec2584551cf68a0a9645.tar.bz2
gentoo-34a7049bb64b825e8708ec2584551cf68a0a9645.zip
x11-terms/kitty-terminfo: split out kitty-terminfo
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch44
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild47
-rw-r--r--x11-terms/kitty-terminfo/metadata.xml15
4 files changed, 107 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
new file mode 100644
index 000000000000..67976bd3bd00
--- /dev/null
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -0,0 +1 @@
+DIST kitty-0.16.0.tar.xz 2974592 BLAKE2B 971e279cd24369a454495fc7a236356e6a4ee69a0953563a9283a16e21bd67ddea5ab8f795c75be6cd31d05c5f1b39b1525e957b9bcd59d12ea3e701b21aa59c SHA512 24dedfc58c5d33aa18da85f904952129f39cd54afb70282c7572b57514b1deebfb532414913e0efc3a5c0352a81406cd7ddef99490dbd9186dc61eab7af3975b
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch
new file mode 100644
index 000000000000..5ff1fa2d77d9
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch
@@ -0,0 +1,44 @@
+--- a/setup.py 2020-03-12 00:28:46.725956882 +0100
++++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
+@@ -876,6 +876,14 @@
+ create_macos_bundle_gunk(ddir)
+ # }}}
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def clean():
+
+@@ -889,7 +897,7 @@
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -910,7 +918,7 @@
+ 'action',
+ nargs='?',
+ default='build',
+- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1007,6 +1015,8 @@
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild
new file mode 100644
index 000000000000..01d70cf00141
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}
diff --git a/x11-terms/kitty-terminfo/metadata.xml b/x11-terms/kitty-terminfo/metadata.xml
new file mode 100644
index 000000000000..2c9e05543121
--- /dev/null
+++ b/x11-terms/kitty-terminfo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pabloorduna98@gmail.com</email>
+ <name>Pablo Orduna</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kovidgoyal/kitty</remote-id>
+ </upstream>
+</pkgmetadata>