summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:10:58 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:18:43 +0200
commit05256085a01c74c23f2169bd7beafc440f7585a6 (patch)
treea1c0900c99a4eb4dbef8df3c2e048c3861527acc /x11-plugins
parentsys-kernel/git-sources: Automated version bump to 4.12_rc3. (diff)
downloadgentoo-05256085a01c74c23f2169bd7beafc440f7585a6.tar.gz
gentoo-05256085a01c74c23f2169bd7beafc440f7585a6.tar.bz2
gentoo-05256085a01c74c23f2169bd7beafc440f7585a6.zip
x11-plugins/wmmand: decompress manpage, bug #619982
Also update EAPI Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmand/wmmand-1.3.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/wmmand/wmmand-1.3.2-r1.ebuild b/x11-plugins/wmmand/wmmand-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..933b07c185b1
--- /dev/null
+++ b/x11-plugins/wmmand/wmmand-1.3.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+MY_P=wmMand-${PV}
+
+DESCRIPTION="a dockable mandelbrot browser"
+HOMEPAGE="http://ciotog.homelinux.net/software/wmMand/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}/wmMand
+
+DOCS=( ../{BUGS,changelog,TODO} )
+
+src_prepare() {
+ default
+ gunzip wmMand.6.gz || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ SYSTEM="${LDFLAGS}" \
+ INCDIR="" LIBDIR=""
+}
+
+src_install() {
+ dobin wmMand
+ doman wmMand.6
+ doicon wmMand.png
+ einstalldocs
+}