summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:11 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:11 +0100
commit91b3ab96eb47e991642dd43493c89d79e8df6b93 (patch)
tree20f0859e4238fc8c6fe590d281470f7255cf5daa /x11-misc
parentx11-misc/wdm: add missing virtual/libcrypt dependency (diff)
downloadgentoo-91b3ab96eb47e991642dd43493c89d79e8df6b93.tar.gz
gentoo-91b3ab96eb47e991642dd43493c89d79e8df6b93.tar.bz2
gentoo-91b3ab96eb47e991642dd43493c89d79e8df6b93.zip
x11-misc/slock: fix library include/search paths, missing libcrypt dependency
Closes: https://bugs.gentoo.org/732410 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slock/files/slock-1.4-fix-link-paths.patch18
-rw-r--r--x11-misc/slock/slock-1.4-r1.ebuild (renamed from x11-misc/slock/slock-1.4.ebuild)14
2 files changed, 29 insertions, 3 deletions
diff --git a/x11-misc/slock/files/slock-1.4-fix-link-paths.patch b/x11-misc/slock/files/slock-1.4-fix-link-paths.patch
new file mode 100644
index 000000000000..503c2e52f7a9
--- /dev/null
+++ b/x11-misc/slock/files/slock-1.4-fix-link-paths.patch
@@ -0,0 +1,18 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 30 Jun 2021 06:54:36 +0100
+Subject: [PATCH] Drop unnecessary include, library paths
+
+Closes: https://bugs.gentoo.org/732410
+--- a/config.mk
++++ b/config.mk
+@@ -11,8 +11,8 @@ X11INC = /usr/X11R6/include
+ X11LIB = /usr/X11R6/lib
+
+ # includes and libs
+-INCS = -I. -I/usr/include -I${X11INC}
+-LIBS = -L/usr/lib -lc -lcrypt -L${X11LIB} -lX11 -lXext -lXrandr
++INCS = -I. -I${X11INC}
++LIBS = -lc -lcrypt -L${X11LIB} -lX11 -lXext -lXrandr
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" -D_DEFAULT_SOURCE -DHAVE_SHADOW_H
diff --git a/x11-misc/slock/slock-1.4.ebuild b/x11-misc/slock/slock-1.4-r1.ebuild
index a15511eda53d..616eee7abe4b 100644
--- a/x11-misc/slock/slock-1.4.ebuild
+++ b/x11-misc/slock/slock-1.4-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit fcaps savedconfig toolchain-funcs
DESCRIPTION="simple X display locker"
@@ -13,6 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~hppa x86"
RDEPEND="
+ virtual/libcrypt:=
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrandr
@@ -22,6 +24,10 @@ DEPEND="
x11-base/xorg-proto
"
+PATCHES=(
+ "${FILESDIR}"/slock-1.4-fix-link-paths.patch
+)
+
src_prepare() {
default
@@ -43,7 +49,9 @@ src_prepare() {
tc-export CC
}
-src_compile() { emake slock; }
+src_compile() {
+ emake slock
+}
src_install() {
dobin slock