summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-16 14:35:28 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-16 14:35:28 +0200
commitf2b7865fe65364124de20ac8d52ee8c0679d213e (patch)
tree61cf7ec0e33ccf70ce17eb76bfdbd3c7f44e1b07 /x11-misc/xsel
parentx11-misc/wininfo: update EAPI 6 -> 8 (diff)
downloadgentoo-f2b7865fe65364124de20ac8d52ee8c0679d213e.tar.gz
gentoo-f2b7865fe65364124de20ac8d52ee8c0679d213e.tar.bz2
gentoo-f2b7865fe65364124de20ac8d52ee8c0679d213e.zip
x11-misc/xsel: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/xsel')
-rw-r--r--x11-misc/xsel/files/xsel-1.2.0-Werror.patch11
-rw-r--r--x11-misc/xsel/xsel-1.2.0-r2.ebuild (renamed from x11-misc/xsel/xsel-1.2.0-r1.ebuild)17
2 files changed, 22 insertions, 6 deletions
diff --git a/x11-misc/xsel/files/xsel-1.2.0-Werror.patch b/x11-misc/xsel/files/xsel-1.2.0-Werror.patch
new file mode 100644
index 000000000000..443dbb909cab
--- /dev/null
+++ b/x11-misc/xsel/files/xsel-1.2.0-Werror.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,7 +24,7 @@
+ dnl Add some useful warnings if we have gcc.
+ dnl changequote(,)dnl
+ if test "x$ac_cv_prog_gcc" = xyes ; then
+- CFLAGS="$CFLAGS -fno-strict-aliasing -Wall -Werror -g -std=gnu99 -Wdeclaration-after-statement -Wno-unused"
++ CFLAGS="$CFLAGS -fno-strict-aliasing -Wall -Wdeclaration-after-statement -Wno-unused"
+ fi
+ dnl changequote([,])dnl
+
diff --git a/x11-misc/xsel/xsel-1.2.0-r1.ebuild b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
index 41a76c336452..0301d4c6ce0b 100644
--- a/x11-misc/xsel/xsel-1.2.0-r1.ebuild
+++ b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Command-line program for getting and setting the contents of the X selection"
HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
@@ -10,14 +12,17 @@ SRC_URI="http://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
LICENSE="HPND"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto
x11-libs/libXt"
-src_compile() {
- emake CFLAGS="${CFLAGS}"
+PATCHES=( "${FILESDIR}"/${P}-Werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
}