summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-03 07:03:16 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-03 21:09:24 +0200
commitb3e0ae8477af38c3f66bdbe470c6f629adab68de (patch)
treeaba91ca791ee07b8662a2c8555cb7bd552755355 /x11-misc/xcape
parentdev-lang/lazarus: fix homepage (diff)
downloadgentoo-b3e0ae8477af38c3f66bdbe470c6f629adab68de.tar.gz
gentoo-b3e0ae8477af38c3f66bdbe470c6f629adab68de.tar.bz2
gentoo-b3e0ae8477af38c3f66bdbe470c6f629adab68de.zip
x11-misc/xcape: Bump to 1.2, by proxied maintainer
Closes: https://bugs.gentoo.org/600570
Diffstat (limited to 'x11-misc/xcape')
-rw-r--r--x11-misc/xcape/Manifest1
-rw-r--r--x11-misc/xcape/xcape-1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xcape/Manifest b/x11-misc/xcape/Manifest
index d7160836b295..f759b87f6786 100644
--- a/x11-misc/xcape/Manifest
+++ b/x11-misc/xcape/Manifest
@@ -1 +1,2 @@
DIST xcape-1.1.tar.gz 18458 SHA256 69ae927a6b2b1268a809b9c3af7c4f94584458f022beb6e2ca3e6bc3ba8a6d4a SHA512 6234e50a38003249eae563ff22ce923c3032e44b358e8e49550001c60246be1159a47f60f52d42040dda88d5396228b8daf4f0f4b03db2bcfc514c634c81540f WHIRLPOOL 1fa89d34143fb98adabdb2b41528352a3f4cd6778324f07ffbd17a921c7fded07a91555eb877361af8452cfd3d516a5eecf6c8ac3ebf565ae89d032ee2c9b06d
+DIST xcape-1.2.tar.gz 18730 SHA256 a27ed884fd94f03058af65a39edfe3af3f2f8fbb76ba9920002a76be07fb2821 SHA512 5ae8502250a9ec55a4b0c5f7301c1597c652b76904261153b720362e3c5882e8db980c85396a2594f99ae2fb72ab7070c1b06c9432d54b7da84975ff45b25a79 WHIRLPOOL a895f38eddfaae2a4408c0e49f1b732283bb4b080f1fd36c8a031ccd7ce51112c58c40f9d9ef4fc1754e51ae2301cd499ad580d0828c937c212331d332354ac0
diff --git a/x11-misc/xcape/xcape-1.2.ebuild b/x11-misc/xcape/xcape-1.2.ebuild
new file mode 100644
index 000000000000..c80f981769a5
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Fix path to man and to pkg-config
+ sed -i \
+ -e '/MANDIR/s:local:share:' \
+ -e 's/pkg-config/${PKG_CONFIG}/' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}