summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-21 08:26:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-21 08:26:35 +0200
commit57b73db3f2ec317c3d287f89b765ca4a8aec166b (patch)
tree6fc0e93bc24e38b5962ea73f59a551268d1246bc /x11-misc/qt5ct
parentdev-python/sqlalchemy: Bump to 1.4.10 (diff)
downloadgentoo-57b73db3f2ec317c3d287f89b765ca4a8aec166b.tar.gz
gentoo-57b73db3f2ec317c3d287f89b765ca4a8aec166b.tar.bz2
gentoo-57b73db3f2ec317c3d287f89b765ca4a8aec166b.zip
x11-misc/qt5ct: Bump to 1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-misc/qt5ct')
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/qt5ct-1.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 89609c72dde1..e8352ff52571 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1 +1,2 @@
DIST qt5ct-1.1.tar.bz2 79890 BLAKE2B e816d76ea35b2133891ccf63be47a227d95dc9783b6f2ac18ee7a7c67bae545fbdc7109103e63c18f093458942ae0b9bab3d1847c40abea9761ab0c314de6357 SHA512 0df00c0680aefb0eada1ddb70886fd63641c403ab42843f8d209413a56895dce0a88eb88a98d09d23a30df3b15ca1d595237592958769a1be86719f2a16cbdf7
+DIST qt5ct-1.2.tar.bz2 76052 BLAKE2B bff9dcd6176f856f262f908101f51be5bc5fa56cbf221fb6e1b66cf49867d721f4c1d5707bcd71cb20b1d27d53f5352bcaaa32ed7298f9fe349ac8a90b4a4e23 SHA512 044582440fc3ed8424970a30d7e1562396f9a1651f2c50adbdcb6ec73b35fb8dd23de419df29b92d21a45fea9af4e562b1294f5bfc329419f831775954f8ed6f
diff --git a/x11-misc/qt5ct/qt5ct-1.2.ebuild b/x11-misc/qt5ct/qt5ct-1.2.ebuild
new file mode 100644
index 000000000000..cadb81998d16
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[dbus]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtpaths:5
+"
+
+src_install() {
+ cmake_src_install
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}