summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-14 20:57:01 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-14 20:57:01 +0100
commit771fb88f375ecc18ed49480258edd123a5fc02ea (patch)
tree72fd2fc21f2f434af881b387a19494cdc53cf567 /x11-drivers
parentx11-drivers/xf86-input-synaptics: Remove old 1.9.0 (diff)
downloadgentoo-771fb88f375ecc18ed49480258edd123a5fc02ea.tar.gz
gentoo-771fb88f375ecc18ed49480258edd123a5fc02ea.tar.bz2
gentoo-771fb88f375ecc18ed49480258edd123a5fc02ea.zip
x11-drivers/xf86-input-synaptics: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
index e226bf3a1265..520fd89d20bd 100644
--- a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
@@ -1,35 +1,44 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit linux-info xorg-2
+inherit linux-info xorg-3
DESCRIPTION="Driver for Synaptics touchpads"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
IUSE="kernel_linux"
-RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+RDEPEND="
>=x11-base/xorg-server-1.14
>=x11-libs/libXi-1.2
- >=x11-libs/libXtst-1.1.0"
-DEPEND="${RDEPEND}
+ >=x11-libs/libXtst-1.1.0
+ kernel_linux? ( >=dev-libs/libevdev-0.4 )"
+DEPEND="
+ ${RDEPEND}
>=sys-kernel/linux-headers-2.6.37
x11-base/xorg-proto"
-DOCS=( "README" )
-
-pkg_pretend() {
+check_reqs() {
linux-info_pkg_setup
+
# Just a friendly warning
if ! linux_config_exists \
|| ! linux_chkconfig_present INPUT_EVDEV; then
- echo
+ ewarn
ewarn "This driver requires event interface support in your kernel"
ewarn " Device Drivers --->"
ewarn " Input device support --->"
ewarn " <*> Event interface"
- echo
+ ewarn
fi
}
+
+pkg_pretend() {
+ check_reqs
+}
+
+pkg_setup() {
+ check_reqs
+}