summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-23 17:56:57 +0000
committerSam James <sam@gentoo.org>2022-01-23 17:57:14 +0000
commit8341ffc0c84fc92b682b4e5b9b46c147f93ad112 (patch)
tree85c639b438ffda4e9419e1749e889c33bc28f189 /www-servers
parentwww-servers/lighttpd: adjust lighttpd.initd (diff)
downloadgentoo-8341ffc0c84fc92b682b4e5b9b46c147f93ad112.tar.gz
gentoo-8341ffc0c84fc92b682b4e5b9b46c147f93ad112.tar.bz2
gentoo-8341ffc0c84fc92b682b4e5b9b46c147f93ad112.zip
www-servers/lighttpd: fix configure arguments for 1.4.64
Bug: https://github.com/gentoo/gentoo/pull/23900 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/files/lighttpd.initd-r179
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.64.ebuild6
2 files changed, 82 insertions, 3 deletions
diff --git a/www-servers/lighttpd/files/lighttpd.initd-r1 b/www-servers/lighttpd/files/lighttpd.initd-r1
new file mode 100644
index 000000000000..f355a5c7232d
--- /dev/null
+++ b/www-servers/lighttpd/files/lighttpd.initd-r1
@@ -0,0 +1,79 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload graceful"
+
+LIGHTTPD_PID="$($(which lighttpd) -pf ${LIGHTTPD_CONF} | grep server.pid-file | cut -d '=' -f 2 | tr -d \\\" | tr -d [:space:])"
+
+depend() {
+ need net
+ use mysql logger spawn-fcgi ldap slapd netmount dns
+ after famd
+ after sshd
+}
+
+checkconfig() {
+ if [ ! -f "${LIGHTTPD_CONF}" ] ; then
+ ewarn "${LIGHTTPD_CONF} does not exist."
+ return 1
+ fi
+
+ if [ -z "${LIGHTTPD_PID}" ] ; then
+ eerror "server.pid-file variable in ${LIGHTTPD_CONF}"
+ eerror "is not set. Please set this variable properly"
+ eerror "and try again"
+ return 1
+ fi
+ /usr/sbin/lighttpd -t -f ${LIGHTTPD_CONF} >/dev/null
+}
+
+start() {
+ checkconfig || return 1
+ # Glean lighttpd's credentials from the configuration file
+ # Fixes bug 454366
+ LIGHTTPD_USER="$(awk '/^server.username/{s=$3};{sub("\"","",s)};END{print s}' ${LIGHTTPD_CONF})"
+ LIGHTTPD_GROUP="$(awk '/^server.groupname/{s=$3};{sub("\"","",s)};END{print s}' ${LIGHTTPD_CONF})"
+ checkpath -d -q -m 0750 -o "${LIGHTTPD_USER}":"${LIGHTTPD_GROUP}" /run/lighttpd/
+
+ ebegin "Starting lighttpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/lighttpd \
+ --pidfile "${LIGHTTPD_PID}" -- -f "${LIGHTTPD_CONF}"
+ eend $?
+}
+
+stop() {
+ local rv=0
+ ebegin "Stopping lighttpd"
+ start-stop-daemon --stop --quiet --pidfile "${LIGHTTPD_PID}"
+ eend $?
+}
+
+reload() {
+ if ! service_started "${SVCNAME}" ; then
+ eerror "${SVCNAME} isn't running"
+ return 1
+ fi
+ checkconfig || return 1
+
+ ebegin "Re-opening lighttpd log files"
+ start-stop-daemon --quiet --pidfile "${LIGHTTPD_PID}" \
+ --signal HUP
+ eend $?
+}
+
+graceful() {
+ if ! service_started "${SVCNAME}" ; then
+ eerror "${SVCNAME} isn't running"
+ return 1
+ fi
+ checkconfig || return 1
+
+ ebegin "Gracefully stopping lighttpd"
+ start-stop-daemon --quiet --pidfile "${LIGHTTPD_PID}" \
+ --signal INT
+ if eend $? ; then
+ rm -f "${LIGHTTPD_PID}"
+ start
+ fi
+}
diff --git a/www-servers/lighttpd/lighttpd-1.4.64.ebuild b/www-servers/lighttpd/lighttpd-1.4.64.ebuild
index 196e483c87bf..567635bdc540 100644
--- a/www-servers/lighttpd/lighttpd-1.4.64.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.64.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -134,13 +134,13 @@ src_configure() {
$(use_with pcre pcre2) \
$(use_with sasl) \
$(use_with ssl openssl) \
- $(use_with system-xxhash) \
+ $(use_with system-xxhash xxhash) \
$(use_with webdav webdav-props) \
$(use_with webdav webdav-locks) \
$(use_with xattr attr) \
$(use_with zlib) \
$(use_with zstd) \
- $(use_with unwind)
+ $(use_with unwind libunwind)
}
src_compile() {