summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-05-23 13:29:40 -0500
committerBen Kohler <bkohler@gentoo.org>2019-05-23 13:29:40 -0500
commitcb863ffe977f4649714bf73ce7040a75d70b705c (patch)
tree7f087c3279cf36fcce6dd1a0c452758fe9197752 /www-client/luakit
parentwww-client/luakit: fix install paths on live build (diff)
downloadgentoo-cb863ffe977f4649714bf73ce7040a75d70b705c.tar.gz
gentoo-cb863ffe977f4649714bf73ce7040a75d70b705c.tar.bz2
gentoo-cb863ffe977f4649714bf73ce7040a75d70b705c.zip
www-client/luakit: fix non-luajit install & tests
This build system defaults to looking for luajit so we need to override LUA_*_NAME when not using luajit. The ebuild had some overrides but not in enough places. This commit should fix install & tests. Closes: https://bugs.gentoo.org/633770 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'www-client/luakit')
-rw-r--r--www-client/luakit/luakit-2017.08.10.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/www-client/luakit/luakit-2017.08.10.ebuild b/www-client/luakit/luakit-2017.08.10.ebuild
index 58974d97427a..487247b7ce74 100644
--- a/www-client/luakit/luakit-2017.08.10.ebuild
+++ b/www-client/luakit/luakit-2017.08.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -56,12 +56,15 @@ src_compile() {
src_test() {
emake \
+ LUA_PKG_NAME=$(usex luajit 'luajit' 'lua') \
LUA_BIN_NAME=$(usex luajit 'luajit' 'lua') \
run-tests
}
src_install() {
emake \
+ LUA_PKG_NAME=$(usex luajit 'luajit' 'lua') \
+ LUA_BIN_NAME=$(usex luajit 'luajit' 'lua') \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
DOCDIR="${ED}/usr/share/doc/${PF}" \