summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-03-23 19:12:25 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-03-23 19:12:25 -0100
commit9f976af02543bc50121b875d575082378f971d52 (patch)
tree7ad98ab1618952d6c8e494f3012a3bb307bee20f /www-apps/drupal
parentmedia-video/ffmpegthumbnailer: Remove 2.1.2 (diff)
downloadgentoo-9f976af02543bc50121b875d575082378f971d52.tar.gz
gentoo-9f976af02543bc50121b875d575082378f971d52.tar.bz2
gentoo-9f976af02543bc50121b875d575082378f971d52.zip
www-apps/drupal: Add second rc for the 8.3.0 release.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-8.3.0_rc2.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index ba4e6e18b8fc..471c99c462c6 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,5 @@
DIST drupal-7.53.tar.gz 3273245 SHA256 36baaac12194658e606d33483443fb4b50ac00f0d25e9c519c6d6a85673cafac SHA512 dafb2a309c59d58154de829fef18af9c1a5caba693d32705e531f38c6bbafe7f89130f3ec28e174c251a62da2a4e00fc339a84310ee077bd708d6c17546d81ec WHIRLPOOL cd1085ccb6097d6a7b2dfb882b34e3d1016674083ed1887719786a4985c4ce1babe6b6417ab5bcfaf6dda32c86f77ed1d58e72d79a27f014b780ea364d092856
DIST drupal-7.54.tar.gz 3275864 SHA256 d74192aca31b56a95bd2b51f205e45293513466eaf902d056e6317dbcffe715b SHA512 0b2834cd2ec7778de1515b99ac7f6348c5a3632a670b882fcce1e3b9d4cc904f9da761c103a3fe70311c69563c8ba5178d76ac8e2938d0831d7ef4113abaaf2a WHIRLPOOL 7aefbecabf5902f97621c3a9ba5cda355a8024390ddfa198dbd20f6ed55187b658fcdb0f39db92a7c7f4e73249d4d191969c8ff9a5d5b13764677a0f50d20f4c
DIST drupal-8.2.7.tar.gz 12090872 SHA256 d56153161be782d2d843bf06a1559b902efc5bef8489c1578daa348efdfd1606 SHA512 8e09243661574452ed7401532b92e261d847aa0aeb34e72dc428fd98d252ad5a8c6c63da505210bdbfb857a9f68bb51172d40bd16e0b8e1dbb0a1290f6b42032 WHIRLPOOL 4a8ddef5030e50bd86dfe6e13d0cfeb188040c9e339a29b5da0d908205a55589e67a8324a01dece1e32f9eb269131f6c35104308df87e6a6f9fd16a8d0c17244
+DIST drupal-8.3.0-rc2.tar.gz 12320512 SHA256 d59b39a259805a15e449799e571574c674c8565e647f614c322015d50e8b919d SHA512 951375a1f9c810505c32fd568e12a5784dac1344cd7d99f8c4cc44e727ae05b6658b4129350986a92fd511f183af410797dcbe8b5f7a2c4a04d157b8bb864f53 WHIRLPOOL 9868192f84d8fde0437c01183008fdbf714d2ed6a632dcb35354dbc4202db66e62f28909ff21e53bc3073ba3fe6e0afe75ef1d9baf9e908037470841324a9dd1
+
diff --git a/www-apps/drupal/drupal-8.3.0_rc2.ebuild b/www-apps/drupal/drupal-8.3.0_rc2.ebuild
new file mode 100644
index 000000000000..a340f8c5fb58
--- /dev/null
+++ b/www-apps/drupal/drupal-8.3.0_rc2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}