summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 13:44:05 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 14:04:13 +0100
commit4c50eada1eb51fcc5294130207b499a34149ae5b (patch)
treeb59921369d4a96dc1af3c5ae4862667f2c779354 /www-apache
parentwww-apache/mod_auth_kerb: update EAPI 5 -> 7 (diff)
downloadgentoo-4c50eada1eb51fcc5294130207b499a34149ae5b.tar.gz
gentoo-4c50eada1eb51fcc5294130207b499a34149ae5b.tar.bz2
gentoo-4c50eada1eb51fcc5294130207b499a34149ae5b.zip
www-apache/mod_auth_radius: add 1.6.0, remove 1.5.8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_radius/Manifest2
-rw-r--r--www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild39
-rw-r--r--www-apache/mod_auth_radius/mod_auth_radius-1.6.0.ebuild39
3 files changed, 40 insertions, 40 deletions
diff --git a/www-apache/mod_auth_radius/Manifest b/www-apache/mod_auth_radius/Manifest
index b8c511508057..c628aca889e7 100644
--- a/www-apache/mod_auth_radius/Manifest
+++ b/www-apache/mod_auth_radius/Manifest
@@ -1 +1 @@
-DIST mod_auth_radius-1.5.8.tar 122880 BLAKE2B 54f1b72cc5c7721c6aead2b0a465c2ddca1264c2a6c196dbf4498c53cc114f1b6afa5467aca5164a39401f0257aed91d8fca1fca4b7e0fe7cd4f04d398ad63a4 SHA512 0fcc43a44ea17b33595a850abb03ff6b92e100dfbeffc82caa9516f6eb7914fb463cb62286d624203a2c7035d05a107dda7b68c5cedf7de3b8be95b9266b6988
+DIST mod_auth_radius-1.6.0.tar.gz 20176 BLAKE2B b004b133a3b8e84533f1e97883436aaec389870c6ca6eb2017bd7f4fac12913c438b9838ff1fce01e5ed26bfeec65f6ac349816ee681f39deea0616c22e2530c SHA512 e128855ab198b35030b798c16538fa33c1698f0f179fccb0d160c2d2cce08f1a7b2ecfaefdc19ae7f21802d38705b7a08414444ac52041b7365a5633e5e66159
diff --git a/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild b/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
deleted file mode 100644
index 831b59d27d9e..000000000000
--- a/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit apache-module epatch
-
-DESCRIPTION="Radius authentication for Apache"
-HOMEPAGE="http://freeradius.org/mod_auth_radius/"
-SRC_URI="ftp://ftp.freeradius.org/pub/radius/${P}.tar"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-APACHE2_MOD_FILE=".libs/mod_auth_radius-2.0.so"
-APACHE2_MOD_DEFINE="AUTH_RADIUS"
-
-APXS2_ARGS="-c ${PN}-2.0.c"
-
-DOCFILES="README"
-
-need_apache2
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-includes.patch"
- if has_version ">=www-servers/apache-2.4"; then
- epatch "${FILESDIR}/${PV}-remote_ip-obsolete.patch"
- fi
-}
-
-src_compile() {
- apache-module_src_compile
-}
-
-src_install() {
- apache-module_src_install
-}
diff --git a/www-apache/mod_auth_radius/mod_auth_radius-1.6.0.ebuild b/www-apache/mod_auth_radius/mod_auth_radius-1.6.0.ebuild
new file mode 100644
index 000000000000..c53926ebd7cd
--- /dev/null
+++ b/www-apache/mod_auth_radius/mod_auth_radius-1.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Radius authentication for Apache"
+HOMEPAGE="https://freeradius.org/sub_projects/ https://github.com/FreeRADIUS/mod_auth_radius/"
+SRC_URI="https://github.com/FreeRADIUS/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+
+APACHE2_MOD_DEFINE="AUTH_RADIUS"
+
+DOCFILES="README.asciidoc"
+
+need_apache2
+
+# Work around Bug #616612
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test ${v} -lt 1.6.0; then
+ ewarn "Please note that upstream has changed the name of this module from"
+ ewarn " ${PN}-2.0.so"
+ ewarn "to simply"
+ ewarn " ${PN}.so"
+ fi
+ done
+ fi
+}