summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 19:20:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 19:20:22 +0100
commitbc220f03a29066eaeb5ec6f0078ebd451d96a976 (patch)
treefb0e2d23e4c745766a670ddbfeaedefc24ace5f1 /sys-process
parentsys-apps/i2c-tools: Remove py3.8-only versions (diff)
downloadgentoo-bc220f03a29066eaeb5ec6f0078ebd451d96a976.tar.gz
gentoo-bc220f03a29066eaeb5ec6f0078ebd451d96a976.tar.bz2
gentoo-bc220f03a29066eaeb5ec6f0078ebd451d96a976.zip
sys-process/criu: Remove py3.8-only versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/criu/Manifest1
-rw-r--r--sys-process/criu/criu-3.14-r2.ebuild138
2 files changed, 0 insertions, 139 deletions
diff --git a/sys-process/criu/Manifest b/sys-process/criu/Manifest
index 4f343f4a67bd..8e3b332bc860 100644
--- a/sys-process/criu/Manifest
+++ b/sys-process/criu/Manifest
@@ -1,4 +1,3 @@
-DIST criu-3.14.tar.bz2 881407 BLAKE2B 418412681baf7ec9d3a03afe3860590c857bffcb6c57d01e60b77e85dd5ba2b30deee280c884ba1574665be5fcfd03f3cc058a4b7ae08f66aabe63a80373089b SHA512 97d064c5ffc41daf6e89edd6208b30e4198f313afc6d621d0dc74dadf94c303be70ba448d4e1ced9500f1c65f1bd12206eb88883be398911cc2c995310b17cc6
DIST criu-3.15.tar.bz2 913904 BLAKE2B 2a3c7ad7ac32a407493e8908886d2929606e1dd0a1dd499be75cb954c1c4d60d0c59f0524d173dcdd89fa638e1edcc0c31886262069e3478173648ef09b4c159 SHA512 7bfd32053e47b95d10cdd5e99494bff6a21aa3179518179f8c72e870f0aab960dd76c9f6cb6982e5b881472cf6962eefee3cf7d8ae9128b3379bcaecc937ebbc
DIST criu-3.16.1.tar.gz 1228535 BLAKE2B 45aa87ee00a18b91474e767dc0326cce6c0942af7771a0c5536751361c171c86ba2065c54587e82b51fd6d7ab116e659324369955086c5237cd7fd26b60d6ce6 SHA512 a558af41f1927a1b1d87f8d11163a5f3d2e4f83a74aba00619b45a6d464d5477a6a0aac3c1b9d9a17e3343a4bf21a3fd6b279b51fa0c347c86c307381a4d0739
DIST criu-3.17.tar.gz 1321713 BLAKE2B 3bc13a7df0da0a17c74e0c12f07b81fe7f294be4d1980647b64c74e35383416ffbc10e7c04398f307bc68ff701f76a9586ea58825057b0df16b40f6aab3cbd0e SHA512 febae66a7820345c0f335f4a49e64c0af5c8ae5d3a394cc0770881b64eab11ca03ad5872f06b0c4ccd1da844c519268dad3b4f8b260267e6d3f582e80d80f804
diff --git a/sys-process/criu/criu-3.14-r2.ebuild b/sys-process/criu/criu-3.14-r2.ebuild
deleted file mode 100644
index ff07deb57d84..000000000000
--- a/sys-process/criu/criu-3.14-r2.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit toolchain-funcs linux-info python-r1
-
-DESCRIPTION="utility to checkpoint/restore a process tree"
-HOMEPAGE="https://criu.org/"
-SRC_URI="https://download.openvz.org/criu/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 -riscv"
-IUSE="doc selinux setproctitle static-libs"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-libs/protobuf-c
- dev-libs/libnl:3
- net-libs/libnet:1.1
- sys-libs/libcap
- selinux? ( sys-libs/libselinux )
- setproctitle? ( dev-libs/libbsd )"
-DEPEND="${RDEPEND}
- doc? (
- app-text/asciidoc
- app-text/xmlto
- )"
-RDEPEND="${RDEPEND}
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
-"
-
-CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
- ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG ~TUN ~NETFILTER_XT_MARK"
-
-# root access required for tests
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/2.2/${PN}-2.2-flags.patch
- "${FILESDIR}"/2.3/${PN}-2.3-no-git.patch
- "${FILESDIR}"/${PN}-3.12-automagic-libbsd.patch
-)
-
-criu_arch() {
- # criu infers the arch from $(uname -m). We never want this to happen.
- case ${ARCH} in
- amd64) echo "x86";;
- arm64) echo "aarch64";;
- ppc64*) echo "ppc64";;
- *) echo "${ARCH}";;
- esac
-}
-
-pkg_setup() {
- use amd64 && CONFIG_CHECK+=" ~IA32_EMULATION"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
-
- if ! use selinux; then
- sed \
- -e 's:libselinux:no_libselinux:g' \
- -i Makefile.config || die
- fi
-
- use doc || sed -i 's_\(install: \)install-man _\1_g' Makefile.install
-}
-
-src_configure() {
- # Gold linker generates invalid object file when used with criu's custom
- # linker script. Use the bfd linker instead. See https://crbug.com/839665#c3
- tc-ld-disable-gold
-
- # Build system uses this variable as a trigger to append coverage flags
- # we'd like to avoid it. https://bugs.gentoo.org/744244
- unset GCOV
-
- python_setup
-}
-
-src_compile() {
- local target="all $(usex doc 'docs' '')"
- emake \
- HOSTCC="$(tc-getBUILD_CC)" \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- PYTHON="${EPYTHON%.?}" \
- FULL_PYTHON="${PYTHON%.?}" \
- OBJCOPY="$(tc-getOBJCOPY)" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- ARCH="$(criu_arch)" \
- V=1 WERROR=0 DEBUG=0 \
- SETPROCTITLE=$(usex setproctitle) \
- ${target}
-}
-
-src_test() {
- # root privileges are required to dump all necessary info
- if [[ ${EUID} -eq 0 ]] ; then
- emake -j1 CC="$(tc-getCC)" ARCH="$(criu_arch)" V=1 WERROR=0 test
- fi
-}
-
-install_crit() {
- "${EPYTHON}" scripts/crit-setup.py install --root="${D}" --prefix="${EPREFIX}/usr/" || die
- python_optimize
-}
-
-src_install() {
- emake \
- ARCH="$(criu_arch)" \
- PREFIX="${EPREFIX}"/usr \
- PYTHON="${EPYTHON%.?}" \
- FULL_PYTHON="${PYTHON%.?}" \
- LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
- DESTDIR="${D}" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- V=1 WERROR=0 DEBUG=0 \
- install
-
- use doc && dodoc CREDITS README.md
-
- python_foreach_impl install_crit
-
- if ! use static-libs; then
- find "${D}" -name "*.a" -delete || die
- fi
-}