summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-22 23:24:17 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-22 23:33:38 +0200
commit4789c8635f3e5ba594a5d810bf3f7a527e5f69f9 (patch)
tree89868a1ff91f8ed3fa7f7ca31886be2de8b711c6 /sys-process
parentapp-benchmarks/bootchart2: fix pycairo dep (diff)
downloadgentoo-4789c8635f3e5ba594a5d810bf3f7a527e5f69f9.tar.gz
gentoo-4789c8635f3e5ba594a5d810bf3f7a527e5f69f9.tar.bz2
gentoo-4789c8635f3e5ba594a5d810bf3f7a527e5f69f9.zip
sys-process/acct: Rename logrotate script (bug #542906)
sys-process/atop checks for "/etc/logrotate.d/psacct" but we named the script just "acct". Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/acct/acct-6.6.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/acct/acct-6.6.4-r1.ebuild b/sys-process/acct/acct-6.6.4-r1.ebuild
new file mode 100644
index 000000000000..efc32e5b78de
--- /dev/null
+++ b/sys-process/acct/acct-6.6.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools systemd
+
+DESCRIPTION="GNU system accounting utilities"
+HOMEPAGE="https://savannah.gnu.org/projects/acct/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.6.4-cross-compile.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-linux-multiformat
+}
+
+src_install() {
+ default
+ keepdir /var/account
+ newinitd "${FILESDIR}"/acct.initd-r2 acct
+ newconfd "${FILESDIR}"/acct.confd-r1 acct
+ systemd_dounit "${FILESDIR}"/acct.service
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/acct.logrotate-r1 psacct
+
+ # sys-apps/sysvinit already provides this
+ rm "${ED}"/usr/bin/last "${ED}"/usr/share/man/man1/last.1 || die
+
+ # accton in / is only a temp workaround for #239748
+ dodir /sbin
+ mv "${ED}"/usr/sbin/accton "${ED}"/sbin/ || die
+}