summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-01-30 19:44:31 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-01-30 19:44:31 +0000
commit41811e6dccc06d1760e3ede11d638f01c947fef1 (patch)
tree54c72db097916d4e12a230f740680e6d5b8deac9 /sys-libs/glibc
parentdev-ml/tiny_httpd: rm dev-ml/seq deps (diff)
downloadgentoo-41811e6dccc06d1760e3ede11d638f01c947fef1.tar.gz
gentoo-41811e6dccc06d1760e3ede11d638f01c947fef1.tar.bz2
gentoo-41811e6dccc06d1760e3ede11d638f01c947fef1.zip
sys-libs/glibc: Backport prefix sysroot change to stable version
Sorry for changing the stable version, but I forgot to consider stable before publishing the news item. This only affects prefix anyway. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.36-r5.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.36-r5.ebuild b/sys-libs/glibc/glibc-2.36-r5.ebuild
index ed09d00c8a98..5aa15579a204 100644
--- a/sys-libs/glibc/glibc-2.36-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r5.ebuild
@@ -1306,6 +1306,17 @@ glibc_do_src_install() {
mv "${ED}"/$(alt_usrlibdir)/libm-${upstream_pv}.a "${ED}"/$(alt_usrlibdir)/${P}/libm-${upstream_pv}.a || die
fi
+ # We configure toolchains for standalone prefix systems with a sysroot,
+ # which is prepended to paths in ld scripts, so strip the prefix from these.
+ # Before: GROUP ( /foo/lib64/libc.so.6 /foo/usr/lib64/libc_nonshared.a AS_NEEDED ( /foo/lib64/ld-linux-x86-64.so.2 ) )
+ # After: GROUP ( /lib64/libc.so.6 /usr/lib64/libc_nonshared.a AS_NEEDED ( /lib64/ld-linux-x86-64.so.2 ) )
+ if [[ -n $(host_eprefix) ]] ; then
+ local file
+ grep -lZIF "ld script" "${ED}/$(alt_usrlibdir)"/lib*.{a,so} 2>/dev/null | while read -rd '' file ; do
+ sed -i "s|$(host_eprefix)/|/|g" "${file}" || die
+ done
+ fi
+
# We'll take care of the cache ourselves
rm -f "${ED}"/etc/ld.so.cache