summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMathis Winterer <mrmagic223325@fedora.email>2022-12-30 17:43:02 +0100
committerSam James <sam@gentoo.org>2023-01-04 05:22:55 +0000
commit78b12c7038b2aa08a4fbb1904b3a94fac790912f (patch)
tree4a471688c16bdfcad9543c9a5a528cb7eecc8b3a /sys-fs
parentdev-python/tox: Keyword 4.1.3 riscv, #888481 (diff)
downloadgentoo-78b12c7038b2aa08a4fbb1904b3a94fac790912f.tar.gz
gentoo-78b12c7038b2aa08a4fbb1904b3a94fac790912f.tar.bz2
gentoo-78b12c7038b2aa08a4fbb1904b3a94fac790912f.zip
sys-fs/duf: new package
Signed-off-by: Mathis Winterer <mrmagic223325@fedora.email> Closes: https://github.com/gentoo/gentoo/pull/28902 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/duf/Manifest2
-rw-r--r--sys-fs/duf/duf-0.8.1.ebuild27
-rw-r--r--sys-fs/duf/metadata.xml20
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/duf/Manifest b/sys-fs/duf/Manifest
new file mode 100644
index 000000000000..789950b0a991
--- /dev/null
+++ b/sys-fs/duf/Manifest
@@ -0,0 +1,2 @@
+DIST duf-0.8.1-deps.tar.xz 6372212 BLAKE2B 01baf089f6142759ef8e376b352e31ecd482f0a94106a4e2606c2f6146cdd7ec33b431621dd680876650896f9d590a21d242b871777164af588e35804a11477e SHA512 51b966b5a8701c8e39ea2d022ca6ee1e0c64fd189b3531d8d0e253d46ee2b5d7270963c3a4930e964312085914edac45c78ed8fa440b459df13977c83ab3c964
+DIST duf-0.8.1.tar.gz 138214 BLAKE2B 388b7494ae15bdc026303ec81f529c08c66e34a8fb82d13c9b7fa730b1684edee5711497d866cbd16376573a386ef9311288e7e9d6143a577d2381425f8218bc SHA512 598318cd90e8a27bdc448cb84682f3846baa02bab0f527a26de42b8b3efd3ba258a76b6f7a74a41405e20b23ccff92db1b6ef7d3412fc8261942a8ccde4241dc
diff --git a/sys-fs/duf/duf-0.8.1.ebuild b/sys-fs/duf/duf-0.8.1.ebuild
new file mode 100644
index 000000000000..5932429d1e48
--- /dev/null
+++ b/sys-fs/duf/duf-0.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Disk Usage/Free Utility - a better 'df' alternative"
+HOMEPAGE="https://github.com/muesli/duf"
+SRC_URI="https://github.com/muesli/duf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/mrmagic223325/duf/releases/download/${PV}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pie"
+
+src_compile() {
+ use pie && GOFLAGS+=" -buildmode=pie"
+ ego build
+}
+
+src_install() {
+ dobin duf
+ dodoc README.md
+ doman duf.1
+}
diff --git a/sys-fs/duf/metadata.xml b/sys-fs/duf/metadata.xml
new file mode 100644
index 000000000000..d6f64e578b80
--- /dev/null
+++ b/sys-fs/duf/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mrmagic223325@fedora.email</email>
+ <name>Mathis Winterer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <name>Christian Muehlhaeuser</name>
+ </maintainer>
+ <bugs-to>https://github.com/muesli/duf/issues</bugs-to>
+ <doc>https://github.com/muesli/duf</doc>
+ <remote-id type="github">muesli/duf</remote-id>
+ </upstream>
+</pkgmetadata>