summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 00:57:00 +0000
committerSam James <sam@gentoo.org>2021-03-10 00:57:00 +0000
commit88f1074d0291e321e9765f358b4806dc9a8ad457 (patch)
tree03687c8d6186a15b37c98869cd7e1f66e39c7599 /sys-fs
parentsys-fs/dmraid: partly modernise latest version (diff)
downloadgentoo-88f1074d0291e321e9765f358b4806dc9a8ad457.tar.gz
gentoo-88f1074d0291e321e9765f358b4806dc9a8ad457.tar.bz2
gentoo-88f1074d0291e321e9765f358b4806dc9a8ad457.zip
sys-fs/dmraid: add musl patch
Closes: https://bugs.gentoo.org/717430 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild4
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc16-musl.patch22
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
index ac268a35d6c6..e76bae706c5d 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
@@ -41,12 +41,16 @@ src_prepare() {
eapply -p0 "${FILESDIR}"/${P}-static-build-fixes.patch
eapply -p3 "${FILESDIR}"/${P}-parallel-make.patch
eapply "${FILESDIR}"/${P}-fix-missing-PATH-MOUNTED.patch
+ eapply "${FILESDIR}"/${PN}-1.0.0_rc16-musl.patch
# pkg_check_modules is not in aclocal.m4 by default, and eautoreconf doesnt add it
einfo "Appending pkg.m4 from system to aclocal.m4"
cat "${BROOT}"/usr/share/aclocal/pkg.m4 >>"${S}"/aclocal.m4 || die "Could not append pkg.m4"
+ mv configure.{in,ac} || die
+
default
+
eautoreconf
einfo "Creating prepatched source archive for use with Genkernel"
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-musl.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-musl.patch
new file mode 100644
index 000000000000..d43ed6354718
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-musl.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/717430
+https://git.alpinelinux.org/aports/plain/main/dmraid/006-musl-libc.patch
+--- a/include/dmraid/misc.h
++++ b/include/dmraid/misc.h
+@@ -10,6 +10,7 @@
+
+ #ifndef _MISC_H_
+ #define _MISC_H_
++#include <fcntl.h>
+
+ #define DM_ASSERT(__cond) do { if (!(__cond)) { printf("ASSERT file:%s line:%d fuction:%s cond: %s\n", __FILE__, __LINE__, __FUNCTION__, #__cond); } } while(0);
+
+--- a/lib/device/scan.c
++++ b/lib/device/scan.c
+@@ -10,6 +10,7 @@
+ # include <dirent.h>
+ # include <paths.h>
+ #else
++# include <paths.h>
+ # include <dirent.h>
+ # include <mntent.h>
+ #endif