summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-12 16:55:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-12 17:36:28 +0300
commitfdbe0726be6e7ba5d4075823ebdeabbad69f8e5e (patch)
tree07a623ece5520ba03d37de115169868a1a5f578e /sys-fs/mdadm
parentdev-cpp/cpp-httplib: change SLOT from 0.17 to 0.17.3 (diff)
downloadgentoo-fdbe0726be6e7ba5d4075823ebdeabbad69f8e5e.tar.gz
gentoo-fdbe0726be6e7ba5d4075823ebdeabbad69f8e5e.tar.bz2
gentoo-fdbe0726be6e7ba5d4075823ebdeabbad69f8e5e.zip
sys-fs/mdadm: drop 4.2-r2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-fs/mdadm')
-rw-r--r--sys-fs/mdadm/mdadm-4.2-r2.ebuild106
1 files changed, 0 insertions, 106 deletions
diff --git a/sys-fs/mdadm/mdadm-4.2-r2.ebuild b/sys-fs/mdadm/mdadm-4.2-r2.ebuild
deleted file mode 100644
index d98a9156fbcb..000000000000
--- a/sys-fs/mdadm/mdadm-4.2-r2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic systemd toolchain-funcs udev
-
-DESCRIPTION="Tool for running RAID systems - replacement for the raidtools"
-HOMEPAGE="https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/"
-DEB_PF="4.2~rc2-7"
-SRC_URI="https://www.kernel.org/pub/linux/utils/raid/mdadm/${P/_/-}.tar.xz
- mirror://debian/pool/main/m/mdadm/${PN}_${DEB_PF}.debian.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-[[ "${PV}" = *_rc* ]] || \
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="static systemd +udev"
-
-REQUIRED_USE="static? ( !udev )"
-
-BDEPEND="app-arch/xz-utils
- virtual/pkgconfig"
-DEPEND="udev? ( virtual/libudev:= )"
-RDEPEND="${DEPEND}
- >=sys-apps/util-linux-2.16"
-
-# The tests edit values in /proc and run tests on software raid devices.
-# Thus, they shouldn't be run on systems with active software RAID devices.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-3.4-sysmacros.patch #580188
- "${FILESDIR}/${PN}"-4.2-in_initrd-collision.patch #830461
-)
-
-mdadm_emake() {
- # We should probably make corosync & libdlm into USE flags. #573782
- local args=(
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- CC="$(tc-getCC)"
- CWFLAGS="-Wall"
- CXFLAGS="${CFLAGS}"
- UDEVDIR="$(get_udevdir)"
- SYSTEMD_DIR="$(systemd_get_systemunitdir)"
- COROSYNC="-DNO_COROSYNC"
- DLM="-DNO_DLM"
-
- # https://bugs.gentoo.org/732276
- STRIP=
-
- "$@"
- )
- emake "${args[@]}"
-}
-
-src_compile() {
- use static && append-ldflags -static
-
- # CPPFLAGS won't work for this
- use udev || append-cflags -DNO_LIBUDEV
-
- # bug 907082
- use elibc_musl && append-cppflags -D_LARGEFILE64_SOURCE
-
- mdadm_emake all
-}
-
-src_test() {
- mdadm_emake test
-
- sh ./test || die
-}
-
-src_install() {
- mdadm_emake DESTDIR="${D}" install install-systemd
- dodoc ChangeLog INSTALL TODO README* ANNOUNCE-*
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm
- newconfd "${FILESDIR}"/mdadm.confd mdadm
- newinitd "${FILESDIR}"/mdraid.rc mdraid
- newconfd "${FILESDIR}"/mdraid.confd mdraid
-
- # From the Debian patchset
- into /usr
- dodoc "${WORKDIR}"/debian/README.checkarray
- dosbin "${WORKDIR}"/debian/checkarray
- insinto /etc/default
- newins "${FILESDIR}"/etc-default-mdadm mdadm
-
- exeinto /etc/cron.weekly
- newexe "${FILESDIR}"/mdadm.weekly mdadm
-}
-
-pkg_postinst() {
- if ! systemd_is_booted; then
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # Only inform people the first time they install.
- elog "If you're not relying on kernel auto-detect of your RAID"
- elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
- elog " rc-update add mdraid boot"
- fi
- fi
-}