summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-16 23:29:30 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-16 23:29:30 +0300
commit9de0ea561d0e620e1649be3ae20b058cebc4fa49 (patch)
treeae8e40879b55c34aaff3af3c6d04d1a22bd46203 /sys-fs/f2fs-tools
parentdev-python/pytest-relaxed-1.1.4: ppc64 stable, bug 663988 (diff)
downloadgentoo-9de0ea561d0e620e1649be3ae20b058cebc4fa49.tar.gz
gentoo-9de0ea561d0e620e1649be3ae20b058cebc4fa49.tar.bz2
gentoo-9de0ea561d0e620e1649be3ae20b058cebc4fa49.zip
sys-fs/f2fs-tools: Version bump (v1.11.0)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.11.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index 307e9b4e764e..46ae091b21af 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1,2 +1,3 @@
DIST f2fs-tools-1.10.0.tar.xz 342904 BLAKE2B ba4dec55e11959b2dd9461b1b02d173c7766908bfdbca9f6da7aa134b4a3b5cf2bda3c2e380b3fab46afdda0be9181ae5fe85ed9d085f816a1ff96e847e2a836 SHA512 e6e9fc10bd8051db86880c415ceb50900bf0cc919f1d9fe39026b5320de7c93cbcc1d817fab73130817042ed551fc5fd55ef9b589caeca9fca63fd3098f7a853
+DIST f2fs-tools-1.11.0.tar.gz 278795 BLAKE2B 8faefb1554283291ad2dc2b66800b88bbdcf07dcb1896a206fd56d52eaa19761c6b008a4961bcec12843a96d2df1744bb5394b4f7bf3830315f4bd3180850e8d SHA512 a69fbd01826909576634f40343293addae3a9c3be09bf8210e2abc1ae12f385fe24dd71c623d14a0a15a81d12f404f193981caaadacbd663bc1502de9a8f7fb7
DIST f2fs-tools-1.6.1.tar.xz 282152 BLAKE2B f8535a5415e012834b749bba2123151d8a39c8fa757905c45be20478d6a795ff64dfbcf0cf9679f2bd70cb1d92717d8df70efb4beb4d749677a6c8758ebdde0e SHA512 108327042079d9e864899a20f2dd94019be1b957fd7ffa295af097c5b93a5065ea9c36de9bae83f84a6412ac496340849fc44de041e24461a2919073eed15cf2
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.11.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.11.0.ebuild
new file mode 100644
index 000000000000..37c94581a16e
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~zlogene/distfiles/${CATEGORY}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}