summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-20 11:52:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-20 11:52:25 +0300
commit3b95c8ba216b7652da47c654ee058a754df58b0f (patch)
tree8c93d9d13b5db14148db2c72d55db87e37f22e7e /sys-fs/f2fs-tools
parentsys-fs/f2fs-tools: amd64 stable wrt bug #666360 (diff)
downloadgentoo-3b95c8ba216b7652da47c654ee058a754df58b0f.tar.gz
gentoo-3b95c8ba216b7652da47c654ee058a754df58b0f.tar.bz2
gentoo-3b95c8ba216b7652da47c654ee058a754df58b0f.zip
sys-fs/f2fs-tools: revbump (new slot)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..700844feff8d
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~zlogene/distfiles/${CATEGORY}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}