summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-fs/eudev
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/eudev')
-rw-r--r--sys-fs/eudev/eudev-3.2.5.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.7-r2.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.8.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.9.ebuild1
-rw-r--r--sys-fs/eudev/eudev-4.9999.ebuild1
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild1
6 files changed, 6 insertions, 0 deletions
diff --git a/sys-fs/eudev/eudev-3.2.5.ebuild b/sys-fs/eudev/eudev-3.2.5.ebuild
index 292095d63780..23b3ca125196 100644
--- a/sys-fs/eudev/eudev-3.2.5.ebuild
+++ b/sys-fs/eudev/eudev-3.2.5.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.7-r2.ebuild b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-3.2.7-r2.ebuild
+++ b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.8.ebuild b/sys-fs/eudev/eudev-3.2.8.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-3.2.8.ebuild
+++ b/sys-fs/eudev/eudev-3.2.8.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.9.ebuild b/sys-fs/eudev/eudev-3.2.9.ebuild
index e56aa608e957..3152f10509ba 100644
--- a/sys-fs/eudev/eudev-3.2.9.ebuild
+++ b/sys-fs/eudev/eudev-3.2.9.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-4.9999.ebuild b/sys-fs/eudev/eudev-4.9999.ebuild
index da2372754cf1..ac45032c4807 100644
--- a/sys-fs/eudev/eudev-4.9999.ebuild
+++ b/sys-fs/eudev/eudev-4.9999.ebuild
@@ -23,6 +23,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
IUSE="+blkid efi +hwdb +kmod selinux smack test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
kmod? ( >=sys-apps/kmod-16 )
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )