summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-09-29 20:11:56 +0200
committerPacho Ramos <pacho@gentoo.org>2024-09-29 20:11:56 +0200
commit8d595a091ec2ee4044a168557013f575558b3e0a (patch)
tree2d17f6935b4ae9f98721425d1f78318db2fe2b2c /sys-firmware
parentmedia-libs/gexiv2: Bump to 0.14.3 (diff)
downloadgentoo-8d595a091ec2ee4044a168557013f575558b3e0a.tar.gz
gentoo-8d595a091ec2ee4044a168557013f575558b3e0a.tar.bz2
gentoo-8d595a091ec2ee4044a168557013f575558b3e0a.zip
sys-firmware/sof-firmware: add 2024.09
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2024.09.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 1cee147d2fb7..1f209b56980c 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-2024.03.tar.gz 8161590 BLAKE2B 23d73ff3ab30b5134086bb21e606805a7d9667adf1a5598a3d31068ba0254dc4c34464ee3913eb3530a8124e3614eff9ba28fa731e9816b28980ea05834c1037 SHA512 1e9891d3891f5a4413a77a68ea6d3a2e6ead8c1a67eaa7e9aaf30871753617ffce19bd3b85ebcbb617e606646f6aa0e1dafee5279c294ec72ef4b2885e009f72
DIST sof-firmware-2024.06.tar.gz 9848270 BLAKE2B 31189e81400981b76db585019324e7dec9f81ff488c6bbc575534d4968ea974764ecf0b585918cc1871e99ef8cff45f77c8c7509bb954360693f3a283b391d6a SHA512 50dbd849b086158af88dd629566b80de4e841dd8a74b6ea8b1d99b3321be94a0d2d6f742b557f0445b9618a6dbeee3fec6a4e9822b320d511ede1ec1812c0d4d
+DIST sof-firmware-2024.09.tar.gz 10196135 BLAKE2B 0136b4ef3500bc09c9411c216c5785c6dc11a1986597b495554b5fa526f843eb19084f15bf11367a3ac942934d1fdc358588cebaa2bcdd8cb74f407a268efdd6 SHA512 b8a199afba7289a39485662741fbf8ecb47e9c91e461478e3e2d523c12986bfddf8a1f61b4ba0a2c689008de8808a2df00f05aacb541a2fb16a6a5dbd7481ecf
diff --git a/sys-firmware/sof-firmware/sof-firmware-2024.09.ebuild b/sys-firmware/sof-firmware/sof-firmware-2024.09.ebuild
new file mode 100644
index 000000000000..105eaae58f37
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2024.09.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+tools"
+
+RDEPEND="
+ tools? (
+ media-libs/alsa-lib
+ sys-libs/glibc
+ )
+"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" || die
+
+ # Drop tools if requested (i.e. useful for musl systems, where glibc
+ # is not available)
+ if ! use tools ; then
+ rm -rv "${D}"/usr/bin || die
+ fi
+}
+
+pkg_preinst() {
+ # Fix sof-ace-tplg directory symlink collisions
+ local sofpath="${EROOT}/lib/firmware/intel/sof-ace-tplg"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}