summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-03-03 12:48:05 -0500
committerMike Gilbert <floppym@gentoo.org>2023-03-06 13:02:11 -0500
commitaa153e0662a8c78bae68eaf1f56348788de62b8c (patch)
tree9117b93700562734d6851f108f444469819e08f0 /sys-devel
parentsys-apps/config-site: new package, add 0 (diff)
downloadgentoo-aa153e0662a8c78bae68eaf1f56348788de62b8c.tar.gz
gentoo-aa153e0662a8c78bae68eaf1f56348788de62b8c.tar.bz2
gentoo-aa153e0662a8c78bae68eaf1f56348788de62b8c.zip
sys-devel/crossdev: depend on sys-apps/config-site
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/crossdev-20230209-r1.ebuild41
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild4
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20230209-r1.ebuild b/sys-devel/crossdev/crossdev-20230209-r1.ebuild
new file mode 100644
index 000000000000..d15bf1ee5010
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20230209-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 4cb66350d4ce..d15bf1ee5010 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
>=sys-apps/portage-2.1
app-shells/bash
sys-apps/gentoo-functions
+ sys-apps/config-site
"
BDEPEND="app-arch/xz-utils"
@@ -34,4 +35,7 @@ src_install() {
if [[ ${PV} == "99999999" ]] ; then
sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
}