summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 17:43:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 22:16:01 +0100
commit3986f34cbdc57db770f9a9901ddd9ad5b6b1c847 (patch)
treed8e8ab31e6f99a43a0cb1218de7b250804723543 /sys-devel/llvm-common/llvm-common-13.0.1.ebuild
parentdev-python/pytables: Stabilize 3.7.0 ppc64, #832280 (diff)
downloadgentoo-3986f34cbdc57db770f9a9901ddd9ad5b6b1c847.tar.gz
gentoo-3986f34cbdc57db770f9a9901ddd9ad5b6b1c847.tar.bz2
gentoo-3986f34cbdc57db770f9a9901ddd9ad5b6b1c847.zip
sys-devel/llvm-common: Bump to 13.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-13.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-13.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-13.0.1.ebuild b/sys-devel/llvm-common/llvm-common-13.0.1.ebuild
new file mode 100644
index 000000000000..3b5304a686ce
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-13.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}