summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-11 22:16:43 +0200
committerAndrew Savchenko <bircoph@gentoo.org>2018-08-08 09:37:59 +0300
commitce75a68d52dfd46fc93551968b8350da6f8e4105 (patch)
treeaa28bfb47951ca3fb67df5f220fa40609ad11fd0 /sys-cluster
parentsys-cluster/pconsole: fix/use HTTPS (diff)
downloadgentoo-ce75a68d52dfd46fc93551968b8350da6f8e4105.tar.gz
gentoo-ce75a68d52dfd46fc93551968b8350da6f8e4105.tar.bz2
gentoo-ce75a68d52dfd46fc93551968b8350da6f8e4105.zip
sys-cluster/pconsole: EAPI7, improve ebuild, add upstream information to
metadata.xml Bug: https://bugs.gentoo.org/648050
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch4
-rw-r--r--sys-cluster/pconsole/metadata.xml3
-rw-r--r--sys-cluster/pconsole/pconsole-1.0-r4.ebuild32
3 files changed, 37 insertions, 2 deletions
diff --git a/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch b/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch
index f306d6408ee8..f06d46ba6b53 100644
--- a/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch
+++ b/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch
@@ -1,5 +1,5 @@
---- pconsole.c 2001-04-09 12:51:49.000000000 +0400
-+++ pconsole.c~vox 2004-08-16 11:37:49.606267087 +0400
+--- a/pconsole.c 2001-04-09 12:51:49.000000000 +0400
++++ b/pconsole.c 2004-08-16 11:37:49.606267087 +0400
@@ -28,6 +28,7 @@
#include "Conn.h"
diff --git a/sys-cluster/pconsole/metadata.xml b/sys-cluster/pconsole/metadata.xml
index 4a09d7ba8d61..e0f52c2e3959 100644
--- a/sys-cluster/pconsole/metadata.xml
+++ b/sys-cluster/pconsole/metadata.xml
@@ -5,4 +5,7 @@
<email>cluster@gentoo.org</email>
<name>Gentoo Cluster Project</name>
</maintainer>
+<upstream>
+ <remote-id type="github">walterdejong/pconsole</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/sys-cluster/pconsole/pconsole-1.0-r4.ebuild b/sys-cluster/pconsole/pconsole-1.0-r4.ebuild
new file mode 100644
index 000000000000..1d6ce3d826e4
--- /dev/null
+++ b/sys-cluster/pconsole/pconsole-1.0-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for managing multiple xterms simultaneously"
+HOMEPAGE="https://github.com/walterdejong/pconsole"
+SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-exit-warn.patch )
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pconsole
+ fperms 4110 /usr/bin/pconsole
+ dodoc ChangeLog README.pconsole public_html/pconsole.html
+}
+
+pkg_postinst() {
+ ewarn "Warning:"
+ ewarn "pconsole installed with suid root!"
+}