summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-12-14 21:26:10 +0100
committerSam James <sam@gentoo.org>2021-12-26 03:38:33 +0000
commit0efd82c754a252ea4422541afc898dd0efbe506f (patch)
tree80d5fe9e7763b28c5abb33f81769f455a5b5dc60 /sys-cluster/legion
parentsys-cluster/legion: drop older ebuilds (diff)
downloadgentoo-0efd82c754a252ea4422541afc898dd0efbe506f.tar.gz
gentoo-0efd82c754a252ea4422541afc898dd0efbe506f.tar.bz2
gentoo-0efd82c754a252ea4422541afc898dd0efbe506f.zip
sys-cluster/legion: bump to EAPI 8 and legion-21.09.0
Bug: https://bugs.gentoo.org/796128 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/23305 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/legion')
-rw-r--r--sys-cluster/legion/Manifest1
-rw-r--r--sys-cluster/legion/legion-21.09.0.ebuild42
-rw-r--r--sys-cluster/legion/legion-9999.ebuild9
3 files changed, 48 insertions, 4 deletions
diff --git a/sys-cluster/legion/Manifest b/sys-cluster/legion/Manifest
new file mode 100644
index 000000000000..52753eefc567
--- /dev/null
+++ b/sys-cluster/legion/Manifest
@@ -0,0 +1 @@
+DIST legion-21.09.0.tar.gz 4017440 BLAKE2B 8f2919ed89f94cd12aff761de0e91ea0b5f9fd6001b83f69f8aff4703df159f001c562ed62ac22404fb15ebecc86a175d7acb528aba2e2d05ef7a6e6c0a9d830 SHA512 ffdbc8fa50100b7feb1709299dc1a9d01f14a6368812a6c5c16fa58746e9627f20863060c3ca25fd8865c8569c5a5f274a0298902bb82f6567b05299f55f6f75
diff --git a/sys-cluster/legion/legion-21.09.0.ebuild b/sys-cluster/legion/legion-21.09.0.ebuild
new file mode 100644
index 000000000000..9487e8eb0a59
--- /dev/null
+++ b/sys-cluster/legion/legion-21.09.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="https://legion.stanford.edu/"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet hwloc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2:= )
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake_src_configure
+}
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index 11c9707d3cfc..9487e8eb0a59 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
@@ -24,7 +24,8 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
hwloc? ( <sys-apps/hwloc-2:= )
- "
+"
+
RDEPEND="${DEPEND}"
src_configure() {
@@ -37,5 +38,5 @@ src_configure() {
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}